Bug 879054 - Error on "virt-manager" when create bonding interfaces by interface(API)
Summary: Error on "virt-manager" when create bonding interfaces by interface(API)
Status: CLOSED DUPLICATE of bug 879055
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.3
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: virt-mgr-maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-21 23:20 UTC by Raul Leite
Modified: 2012-11-21 23:54 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-11-21 23:54:17 UTC


Attachments (Terms of Use)

Description Raul Leite 2012-11-21 23:20:52 UTC
Description of problem:
Error on "virt-manager" when create bonding interfaces by interface(API)

Version-Release number of selected component (if applicable):

How reproducible:

When sysadmin tries to create a bond interface by API of (virt-manager), they put a wrongs single quotes inside of configuration file on "/etc/sysconfig/network-scripts/ifcfg-<bond_name>", and if you check /proc/net/bonding/<bond_name> status they don't show a correct mode selected by sysadmin, As show bellow :

Wrong
BONDING_OPTS="'mode=active-backup'" 

Should be
BONDING_OPTS="mode=active-backup" 

Wihout '' (single quotes).


Steps to Reproduce:
1. Setting up a bond interface by virt-manager API
2.
3.
  
Actual results:
Error on configuration /etc/sysconfig/network-scripts/ifcfg-<bond_name>


Expected results:


Additional info:

Comment 2 Raul Leite 2012-11-21 23:54:17 UTC

*** This bug has been marked as a duplicate of bug 879055 ***


Note You need to log in before you can comment on or make changes to this bug.