Bug 879067 - Search for project names giving unexpected results
Search for project names giving unexpected results
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 19:17 EST by Hedda Peters
Modified: 2012-11-21 23:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-21 23:52:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Michelle Kim 2012-11-21 20:09:42 EST
I believe it is a bug for project search feature. Can anyone in the dev team take a look at this? thank you.
Comment 2 David Mason 2012-11-21 23:11:29 EST
This happens because the project search is using a word-based search without wildcards, so basically if the string does not match the entire word it will not show up as a result.

For example if there is a project with "cloudforms" in the description, at the moment a search of "cloud" or "forms" will not match (unless those words appear in addition to "cloudforms").

The fixes for this would be either adding wildcards to the search, or changing to an n-gram approach that would match substrings regardless of words.
Comment 3 Hedda Peters 2012-11-21 23:25:39 EST
That would make sense if it didn't show me any results when searching for "cloud". Why does it give me 1 result named "Cloudforms" though?
Comment 4 David Mason 2012-11-21 23:48:24 EST
Note that the word "cloud" is present in the name, slug or description for each of the results for a search of "cloud". The fact that "Cloudforms" is also present is just a coincidence in this case.

Note that for the purpose of this search, words can be separated by whitespace or by things like hyphens or underscores.
Comment 5 Hedda Peters 2012-11-21 23:52:32 EST
Aaaaaah..... the 1 result is "Cloudforms CLOUD Engine User Guide". Of course it's being found searching for "cloud" - I was too focused on "cloudforms" to see the second, separte occurance of "cloud" in the name. (oops)

Closing, sorry!

Note You need to log in before you can comment on or make changes to this bug.