Bug 879142 - When passing inst.repo=hd , anaconda shows 'Error setting up software source', but in fact it works fine
When passing inst.repo=hd , anaconda shows 'Error setting up software source'...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-11-22 02:48 EST by Adam Williamson
Modified: 2012-12-06 07:01 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-18.35-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 02:28:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
all typical logs pasted together (511.68 KB, text/plain)
2012-11-30 02:13 EST, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2012-11-22 02:48:27 EST
Performing https://fedoraproject.org/wiki/QA:Testcase_install_repository_Hard_drive_variation against F18 Beta RC1. I set up a VM with two disks, created a single ext4 partition on the second and placed a 'DVD.iso' (F18 Beta RC1 DVD iso) file on it, booted from F18 beta RC1 netinst and passed 'inst.repo=hd:vdb1:/DVD.iso'. The hub showed 'Error setting up software source' as the comment for the install source spoke, but no warning triangle, and it allowed me to proceed with installation after selecting the other disk as the install target. The install seemed to proceed correctly and use the ISO as the install source (I killed dhclient to take the network connection down, and install carried on just fine, so it wasn't using a remote repo). So it worked, but the error message is rather confusing.
Comment 1 Chris Lumens 2012-11-23 23:59:16 EST
When you got the error triangle, did you go into the spoke to see if there was a more verbose error message?  Also, can you attach the usual log files?
Comment 2 Adam Williamson 2012-11-24 03:24:10 EST
I don't recall. I'll try and re-test and provide the logs.
Comment 3 Adam Williamson 2012-11-30 02:00:29 EST
Okay, I reproduced this, just as before. Remember, the message says 'Error setting up software source' but there is *not* an error triangle.

Entering the spoke I see the 'ISO file' radio button selected, and the 'Device:' dropdown is set to 'Virtio Block Device (9999 MB)', with a very small box between that dropdown and the Verify button, which doesn't look like it contains anything. There is no error message.

On the Installation Destination screen, I can pick the 10GB disk which the ISO is on, and no warning or error is shown, and the Installation Source spoke does not enter any error condition. When I do that, though, it looks like it doesn't actually format or create any partitions on vdb, so that's okay, I guess.

/dev/vdb1 is mounted on /run/install/isodir .

I'll attach the logs from a completed install when it's done.
Comment 4 Adam Williamson 2012-11-30 02:13:44 EST
Created attachment 654850 [details]
all typical logs pasted together

attaching all the logs in one file for convenience. note that unmounting the repo fails at the end of install, after a while it times out and shows the 'complete' message.
Comment 5 Adam Williamson 2012-11-30 02:22:35 EST
Note this bug is the same in final-smoke1 (using anaconda 18.32).
Comment 6 Kamil Páral 2012-12-03 04:24:27 EST
Bug confirmed. We might want to argue whether this is just a cosmetic problem or a blocker:
The installer must be able to use all supported local and remote package source options.
http://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 7 Chris Lumens 2012-12-03 11:49:44 EST
Helps if we look in the right directory for a mounted image.
Comment 8 Fedora Update System 2012-12-04 19:56:48 EST
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18
Comment 9 Fedora Update System 2012-12-05 18:12:57 EST
Package pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.22-1.fc18 anaconda-18.35-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-12-06 02:28:53 EST
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Kamil Páral 2012-12-06 07:01:57 EST
This works in anaconda 18.36.

Note You need to log in before you can comment on or make changes to this bug.