Bug 879290 - fedup-prepared system does not boot System Upgrade by default
Summary: fedup-prepared system does not boot System Upgrade by default
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedup
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Will Woods
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-22 14:43 UTC by Kamil Páral
Modified: 2013-01-03 07:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-03 07:26:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Páral 2012-11-22 14:43:12 UTC
Description of problem:
Fedup creates "System Upgrade" menu item in GRUB, but it is not selected by default. Therefore if a user reboots machine and doesn't notice there is a new menu item (e.g. F17 UEFI GRUB is hidden by default), the user will have no idea why the upgrade is not started (fedup instructions are "reboot the computer to start the upgrade").

Version-Release number of selected component (if applicable):
fedup-0.7.1-1.fc17

How reproducible:
always

Comment 1 Tim Flink 2012-11-22 17:29:31 UTC
This is actually by design. I don't recall the details of why off hand but I think it had something to do with problems caused by making the 'System Upgrade' option default. Will would know more.

Comment 2 Will Woods 2012-11-23 19:58:40 UTC
Right - we intend to use grub2-reboot to set the default boot entry for the *next boot only*. Resetting the default in the bootloader config could result in nasty reboot loops if anything goes wrong with the upgrade.

Comment 3 Fedora Update System 2012-12-21 04:49:21 UTC
fedup-0.7.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedup-0.7.2-1.fc17

Comment 4 Fedora Update System 2012-12-21 12:09:51 UTC
Package fedup-0.7.2-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.7.2-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20801/fedup-0.7.2-1.fc17
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-01-03 07:26:33 UTC
fedup-0.7.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.