Bug 879377 - [abrt] yum-utils-1.1.31-4.fc17: yumRepo.py:513:check:RepoError: Cannot find a valid baseurl for repo: rpmfusion-free-updates/rawhide/x86_64
[abrt] yum-utils-1.1.31-4.fc17: yumRepo.py:513:check:RepoError: Cannot find a...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:934dffffcc87884ebc692ee2918...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-22 12:44 EST by Sergio Monteiro Basto
Modified: 2013-06-02 21:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-02 21:12:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: environ (3.03 KB, text/plain)
2012-11-22 12:44 EST, Sergio Monteiro Basto
no flags Details
File: dso_list (24 bytes, text/plain)
2012-11-22 12:44 EST, Sergio Monteiro Basto
no flags Details
File: executable (14 bytes, text/plain)
2012-11-22 12:44 EST, Sergio Monteiro Basto
no flags Details
File: smolt_data (3.32 KB, text/plain)
2012-11-22 12:44 EST, Sergio Monteiro Basto
no flags Details
File: core_backtrace (2.17 KB, text/plain)
2012-11-22 12:44 EST, Sergio Monteiro Basto
no flags Details

  None (edit)
Description Sergio Monteiro Basto 2012-11-22 12:44:31 EST
Description of problem:
enabling rpmfusion repos and doing: 
repoquery --releasever=rawhide x264-libs --whatrequires 


[rpmfusion-free-rawhide]
name=RPM Fusion for Fedora Rawhide - Free
#baseurl=http://download1.rpmfusion.org/free/fedora/development/rawhide/$basearch/os/
mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-rawhide&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-latest-$basearch file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-rawhide-$basearch

[rpmfusion-free-rawhide-source]
name=RPM Fusion for Fedora Rawhide - Free - Source
#baseurl=http://download1.rpmfusion.org/free/fedora/development/rawhide/source/SRPMS/
mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-rawhide-source&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-latest-$basearch file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-rawhide-$basearch

[rpmfusion-nonfree-rawhide]
name=RPM Fusion for Fedora Rawhide - Nonfree
#baseurl=http://download1.rpmfusion.org/nonfree/fedora/development/$basearch/os/
mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-rawhide&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-latest-$basearch file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-rawhide-$basearch

[rpmfusion-nonfree-rawhide-source]
name=RPM Fusion for Fedora Rawhide - Nonfree - Source
#baseurl=http://download1.rpmfusion.org/nonfree/fedora/development/source/SRPMS/
mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-rawhide-source&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-latest-$basearch file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-rawhide-$basearch



Version-Release number of selected component:
yum-utils-1.1.31-4.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python -tt /bin/repoquery --releasever=rawhide x264-libs --whatrequires --source
kernel:         3.6.6-1.fc17.x86_64

backtrace:
:yumRepo.py:513:check:RepoError: Cannot find a valid baseurl for repo: rpmfusion-free-updates/rawhide/x86_64
:
:Traceback (most recent call last):
:  File "/bin/repoquery", line 1510, in <module>
:    main(sys.argv)
:  File "/bin/repoquery", line 1504, in main
:    repoq.runQuery(regexs)
:  File "/bin/repoquery", line 988, in runQuery
:    for p in self.doQuery(oper, prco):
:  File "/bin/repoquery", line 1027, in doQuery
:    return getattr(self, "fmt_%s" % method)(*args, **kw)
:  File "/bin/repoquery", line 1066, in fmt_whatrequires
:    require_recursive(name)
:  File "/bin/repoquery", line 1051, in require_recursive
:    for pkg in self.returnByName(name):
:  File "/bin/repoquery", line 839, in returnByName
:    pkgs = self.returnPkgList(patterns=[name])
:  File "/bin/repoquery", line 856, in returnPkgList
:    pkgs = self.pkgSack.returnNewestByNameArch(**kwargs)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1013, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 779, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 309, in populateSack
:    self.doSetup()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 134, in doSetup
:    self.retrieveAllMD()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 84, in retrieveAllMD
:    dl = repo._async and repo._commonLoadRepoXML(repo)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1365, in _commonLoadRepoXML
:    result = self._getFileRepoXML(local, text)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1143, in _getFileRepoXML
:    size=102400) # setting max size as 100K
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 950, in _getFile
:    result = self.grab.urlgrab(misc.to_utf8(relative), local,
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 626, in <lambda>
:    grab = property(lambda self: self._getgrab())
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 621, in _getgrab
:    self._setupGrab()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 586, in _setupGrab
:    urls = self.urls
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 806, in <lambda>
:    urls = property(fget=lambda self: self._geturls(),
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 803, in _geturls
:    self._baseurlSetup()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 769, in _baseurlSetup
:    self.check()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 513, in check
:    'Cannot find a valid baseurl for repo: %s' % self.ui_id
:RepoError: Cannot find a valid baseurl for repo: rpmfusion-free-updates/rawhide/x86_64
:
:Local variables in innermost frame:
:self: <yum.yumRepo.YumRepository object at 0x1f87750>
Comment 1 Sergio Monteiro Basto 2012-11-22 12:44:34 EST
Created attachment 649966 [details]
File: environ
Comment 2 Sergio Monteiro Basto 2012-11-22 12:44:36 EST
Created attachment 649967 [details]
File: dso_list
Comment 3 Sergio Monteiro Basto 2012-11-22 12:44:37 EST
Created attachment 649968 [details]
File: executable
Comment 4 Sergio Monteiro Basto 2012-11-22 12:44:39 EST
Created attachment 649969 [details]
File: smolt_data
Comment 5 Sergio Monteiro Basto 2012-11-22 12:44:41 EST
Created attachment 649970 [details]
File: core_backtrace
Comment 6 Sergio Monteiro Basto 2013-01-20 21:52:08 EST
(In reply to comment #0)
> Description of problem:
> enabling rpmfusion repos and doing: 
> repoquery --releasever=rawhide x264-libs --whatrequires 

Hi, 
if I disable rpmfusion updates repos 

yum repolist
fedora/17/x86_64
rpmfusion-free/17/x86_64
rpmfusion-nonfree/17/x86_64 
updates/17/x86_64

It works . Why repoquery try use rpmfusion updates ?  since I ask for rawhide repo. 
(Cannot find a valid baseurl for repo: rpmfusion-free-updates/rawhide/x86_64)
Comment 7 Sergio Monteiro Basto 2013-06-02 21:12:51 EDT
when we query rawhide we need disable updates, like this:
repoquery --releasever=rawhide --disablerepo=\*updates\* x264-libs --whatrequires 

meanwhile no more backtraces, so close it with fix in current release.

Note You need to log in before you can comment on or make changes to this bug.