Bug 879477 - bluetooth tethering doesn't work
bluetooth tethering doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Don Zickus
Fedora Extras Quality Assurance
:
: 884334 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-23 01:22 EST by Samuel Sieb
Modified: 2013-08-26 20:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 20:18:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
advertise the right interface (554 bytes, patch)
2012-11-23 13:21 EST, Samuel Sieb
no flags Details | Diff

  None (edit)
Description Samuel Sieb 2012-11-23 01:22:23 EST
Bluetooth tethering fails due to the following error:

Nov 22 22:15:47 hostname NetworkManager[688]: <warn> Error connecting with bluez: Method "Connect" with signature "s" on interface "org.bluez.Network" doesn't exist

I checked the upstream bluez repository and that's the right signature, but the bluez version in Fedora doesn't have it.  The web interface doesn't seem to have the annotate or blame options so I can't tell when it was changed.  But NetworkManager is expecting that interface signature.
Comment 1 Samuel Sieb 2012-11-23 13:21:37 EST
Created attachment 650594 [details]
advertise the right interface

With this patch, I can successfully tether my phone over bluetooth.
Comment 2 Christopher Beland 2013-02-20 15:28:31 EST
*** Bug 884334 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Admin XMLRPC Client 2013-08-26 10:25:30 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Samuel Sieb 2013-08-26 20:18:30 EDT
I just realized this has been fixed.  At some point there was a new version released which I upgraded to from my version and it's still working.

Note You need to log in before you can comment on or make changes to this bug.