Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 879490 - gluster peer probe --xml outputs wrong xml format
Summary: gluster peer probe --xml outputs wrong xml format
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs
Version: 2.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Avra Sengupta
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-23 07:01 UTC by Bala.FA
Modified: 2015-11-23 02:57 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.4.0qa8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-23 22:34:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bala.FA 2012-11-23 07:01:40 UTC
Description of problem:
"gluster peer probe <hostname> --xml" outputs wrong xml in case of error

<?xml version="1.0"?>
<cliOutput>
  <opRet>-1</opRet>
  <opErrno>107</opErrno>
  <opErrstr>(null)</opErrstr>
  <cliOp>peerProbe</cliOp>
  <output>Probe unsuccessful
Probe returned with unknown errno 107</output>
</cliOutput>


Version-Release number of selected component (if applicable):
glusterfs 3.3.0rhsvirt1-8.el6rhs

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
<?xml version="1.0"?>
<cliOutput>
  <opRet>-1</opRet>
  <opErrno>107</opErrno>
  <opErrstr>Probe unsuccessful Probe returned with unknown errno 107</opErrstr></cliOutput>


Additional info:

Comment 2 Vijay Bellur 2012-12-19 03:15:27 UTC
CHANGE: http://review.gluster.org/4301 (cli: Fixing the xml output in failure cases for gluster peer probe) merged in master by Anand Avati (avati@redhat.com)

Comment 4 Vijay Bellur 2012-12-19 08:49:54 UTC
CHANGE: http://review.gluster.org/4335 (cli: Making the op-ret check for gluster peer probe --xml more robust.) merged in master by Vijay Bellur (vbellur@redhat.com)

Comment 5 Prasanth 2013-05-02 06:52:54 UTC
Verified as fixed in glusterfs-3.4.0qa8

----------
# gluster peer probe qa-vm06.lab.eng.blr.redhat.com  --xml
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>-1</opRet>
  <opErrno>107</opErrno>
  <opErrstr>Probe returned with unknown errno 107</opErrstr>
</cliOutput>
----------

Comment 6 Scott Haines 2013-09-23 22:34:36 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html


Note You need to log in before you can comment on or make changes to this bug.