This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 879536 - Add use-rsync-xattrs to geo-replication
Add use-rsync-xattrs to geo-replication
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.3.0
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Csaba Henk
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-23 04:17 EST by Alexander Sopicki
Modified: 2013-03-19 03:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: xtimes are transferred from master to slave synchronously Consequence: Above op is a major bottleneck especisally for small file layouts. Fix: Add a mode where rsync is used to transfer xtimes (and other extended attributes). Result: Partial fix -- increased speed, reduced correctness, cf. doc text of https://bugzilla.redhat.com/show_bug.cgi?id=764075. Alternative approach would be to implement asynchronous xtime transfer.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 03:51:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Sopicki 2012-11-23 04:17:07 EST
Description of problem:

Currently geo-replication is slow for directories with a large amount of small files due to the sync of the xtime for all files. This option is only available in the master branch. Please integrate the feature in the 3.3.2 version of GlusterFS.

Version-Release number of selected component (if applicable): 3.3.0


How reproducible:

Create a directory with thousands (>50.000) of small files (e.g. images) and setup geo-replication.
  

Actual results:

Geo-replication checks every file in the directory which is very slow for directories with a large amount of files.

Expected results:

Geo-replication should only consider those files which have actually changed to speed up the process.
Comment 1 Csaba Henk 2013-03-19 03:51:15 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=841062 implements this for mainline.

We are not so eager for the backport now so mark WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.