Bug 879542 - Kernel panic occurs during auto installation if there were two PV existing
Kernel panic occurs during auto installation if there were two PV existing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-23 04:34 EST by shaochen
Modified: 2013-02-28 11:45 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-10.el6
Doc Type: Bug Fix
Doc Text:
In an automatic installation, a kernel panic occurred when there are two or more LVM physical volumes (PV) and not all are referenced in the storage_init parameter. This fix ensures dracut shows the missing PV elements during the installation when attempting to remove LVM metadata.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:45:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel panic (121.13 KB, image/jpeg)
2012-12-04 21:30 EST, shaochen
no flags Details

  None (edit)
Description shaochen 2012-11-23 04:34:13 EST
Description of problem:
Kernel panic occurs during auto installation if there were two PV existing.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121120.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H on two pv(e.g. ata + usb).
2. Reboot host and enter boot media.
3. Auto install RHEV-H to ata(e.g. storage_init=/dev/sda firstboot).
  
Actual results:
1. Kernel panic - not syncing: Attempted to kill init!
2. After step 2, TUI install can successful.

Expected results:
Auto install can successful without kernel panic.

Additional info:
No such issue in rhev-hypervisor6-6.3-20121121.0.el6_3 version, so it is a regression bug.
Comment 10 shaochen 2012-12-04 21:30:49 EST
Created attachment 657889 [details]
kernel panic

Upload the kernel panic screenshot from serial console for you reference.
Comment 16 errata-xmlrpc 2013-02-28 11:45:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.