Bug 879637 - Some of the piglit tests segfault with error in i965_dri.so
Some of the piglit tests segfault with error in i965_dri.so
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mesa (Show other bugs)
6.4
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Dave Airlie
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-23 09:24 EST by Jiri Koten
Modified: 2016-03-09 08:18 EST (History)
2 users (show)

See Also:
Fixed In Version: mesa-9.2-0.1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 01:22:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (83.08 KB, text/plain)
2012-11-23 09:24 EST, Jiri Koten
no flags Details

  None (edit)
Description Jiri Koten 2012-11-23 09:24:14 EST
Created attachment 650461 [details]
dmesg output

Description of problem:
After running piglit quick-driver test I have found couple of segfaults in dmesg output.

I run the tests on SandyBridge Desktop GT2+ [8086:0122]

[snip]
...
draw-elements-b[12302]: segfault at 7fffc119f500 ip 00000037d7a89866 sp 00007fffc1195ec8 error 4 in libc-2.12.so[37d7a00000+18a000]
glx-create-cont[13605]: segfault at 37d7da42c0 ip 00007f2b99a91ac5 sp 00007fff0db362b0 error 4 in i965_dri.so[7f2b99a6a000+c7000]
glx-create-cont[13770]: segfault at 37d7da42c0 ip 00007f3711107ac5 sp 00007fff69431160 error 4 in i965_dri.so[7f37110e0000+c7000] 

Version-Release number of selected component (if applicable):
kernel-2.6.32-342.el6
mesa-dri-drivers-9.0-0.2.el6
xorg-x11-drv-intel-2.20.2-2.el6
xorg-x11-server-Xorg-1.13.0-7.el6


How reproducible:
100%

Steps to Reproduce:
1. piglit-run /usr/lib64/piglit/tests/quick-driver.tests /tmp/piglit
2. check the dmesg output
Comment 1 Dave Airlie 2012-11-28 19:16:06 EST
are these regressions? we generally only care about piglit regressions, since the last release, these should probably be investigated upstream.
Comment 2 RHEL Product and Program Management 2012-12-14 02:25:23 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Jiri Koten 2013-04-10 04:55:53 EDT
Unfortunately we don't have test results to compare with. We will retest with next rebase.
Comment 4 Adam Jackson 2013-06-26 10:30:50 EDT
I'm calling this MODIFIED since 9.2 assuredly at least fails in different ways, and we shouldn't see any crashes out of piglit at all imo.
Comment 10 errata-xmlrpc 2013-11-21 01:22:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1559.html

Note You need to log in before you can comment on or make changes to this bug.