Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 879670 - DBInitializerException When starting portal on oracle DBs
Summary: DBInitializerException When starting portal on oracle DBs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Default User
QA Contact: vramik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-23 16:16 UTC by vramik
Modified: 2013-11-05 00:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-16 08:55:50 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker GTNPORTAL-2739 0 Major Resolved Add db-tablename-suffix property to JCR configuration to make it Oracle ready 2015-06-09 09:02:58 UTC

Comment 1 Viliam Rockai 2012-11-26 17:34:48 UTC
The problem is caused by Oracle DB constrain - the name of identifier can't be longer then 30 characters. If the isolated JCR mode is set (gatein.jcr.db-structure-type=isolated in configuration.properties), the JCR tries to create objects with identifiers longer then 30 chars, i.e.: JCR_IDX_IPORTALSYSTEM_PARENT_FK, which leads to the "ORA-00972: identifier is too long" error.

I can think of 3 different ways to resolve this problem:
1. (Prefered) Turn off the "isolated" mode and use "single" as in the previous EPP/JPP versions. The isolated mode can be a feature of JPP, which is not turned on by default.

2. Rename the JPP workspaces to much shorter names, like "portal-system"-"p-sys", "portal-work"->"p-work". 

3. Reconfigure databases in the lab. I'm not sure if this is possible to do.

Comment 2 Viliam Rockai 2012-11-28 15:14:37 UTC
The problem is in the datasouce configuration. You are disabling the JTA (setting jta=false), but the default value in gatein/jpp is jta=true. Deleting jta=false from the datasouce configuration (true is the default value) resolves this problem.


Note You need to log in before you can comment on or make changes to this bug.