Bug 879812 - audit2allow is missing
Summary: audit2allow is missing
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot   
(Show other bugs)
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-24 16:04 UTC by Brian Lane
Modified: 2013-09-23 17:51 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1002167 (view as bug list)
Environment:
Last Closed: 2013-01-15 02:30:50 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Lane 2012-11-24 16:04:41 UTC
Description of problem:
audit2allow is missing from policycoreutils-python-2.1.13-34

sealert is having problems running:

/bin/sh: audit2allow: command not found
-R: audit2allow: command not found

Comment 1 Miroslav Grepl 2012-11-26 11:16:09 UTC
# yum install policycoreutils-devel


will fix it for now.

Comment 2 Daniel Walsh 2012-11-27 12:22:27 UTC
setroubleshoot-3.1.19-1.fc18 makes this optional.

Comment 3 Carlos Soriano 2012-12-05 20:02:22 UTC
Also, when you click troubleshooting, the instructions tell you to run audit2allow, and it is not installed by default and it's very dificult to find which package has audit2allow.
So you go to troubleshooting and you have problems with the trobleshouting also, it is very anoying and IMHO it have not to happens.
I think the best solution will be to install by default the package policycoreutils-devel

Comment 4 Daniel Walsh 2012-12-05 21:57:19 UTC
yum install /usr/bin/audit2allow 

Should have installed the correct package.

I will add this as default to setroubleshoot requires.  But we still do not have it on the server only install.  The problem is audit2allow brings in lots of requirements for selinux-policy-devel package, which is rather large, and we are trying to minimize the minimal install.

Fixed in setroubleshoot-3.1.19

Comment 5 Fedora Update System 2012-12-06 11:45:30 UTC
setroubleshoot-3.1.19-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/setroubleshoot-3.1.19-2.fc18

Comment 6 Fedora Update System 2012-12-06 20:07:10 UTC
Package setroubleshoot-3.1.19-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing setroubleshoot-3.1.19-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19841/setroubleshoot-3.1.19-2.fc18
then log in and leave karma (feedback).

Comment 7 Eric 2012-12-11 21:22:31 UTC
(In reply to comment #6)
> Package setroubleshoot-3.1.19-2.fc18:
> * should fix your issue,
>
Does not look like it is working:

# yum install setroubleshoot
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package setroubleshoot.i686 0:3.1.19-2.fc18 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================
 Package             Arch      Version             Repository            Size
==============================================================================
Installing:
 setroubleshoot      i686      3.1.19-2.fc18       updates-testing      120 k

Transaction Summary
==============================================================================
Install  1 Package

Total download size: 120 k
Installed size: 227 k
Is this ok [y/N]: y
Downloading Packages:
setroubleshoot-3.1.19-2.fc18.i686.rpm                      | 120 kB   00:02     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : setroubleshoot-3.1.19-2.fc18.i686                            1/1 
  Verifying  : setroubleshoot-3.1.19-2.fc18.i686                            1/1 

Installed:
  setroubleshoot.i686 0:3.1.19-2.fc18                                           

Complete!
# audit2allow
bash: audit2allow: command not found...

Comment 8 Daniel Walsh 2012-12-11 21:46:48 UTC
Shoot, I guess not.

I will fix in the next version.

setroubleshoot-3.1.19-3.fc18.i686

Comment 9 Daniel Walsh 2012-12-11 21:58:19 UTC
Please try the new version, hopefully I will not have my head up my butt this time.

Comment 10 Fedora Update System 2012-12-12 20:40:02 UTC
Package setroubleshoot-3.1.19-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing setroubleshoot-3.1.19-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19841/setroubleshoot-3.1.19-3.fc18
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-01-15 02:30:54 UTC
setroubleshoot-3.1.19-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Michel Alexandre Salim 2013-07-07 17:50:36 UTC
This problem is reoccuring with setroubleshoot-3.2.10-1.fc19.x86_64 -- it no longer pulls in policycoreutils-devel but troubleshooting instructions refer to audit2allow.

Should I reopen this or do you prefer a separate bug report?

Comment 13 Chandan 2013-07-13 07:29:20 UTC
Just now I installed Fedora 19 got the same error.

grep chrome /var/log/audit/audit.log | audit2allow -M mypol
bash: audit2allow: command not found...

Linux localhost.localdomain 3.9.5-301.fc19.x86_64 #1 SMP Tue Jun 11 19:39:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Comment 14 Robert Muil 2013-08-06 07:17:39 UTC
I also experience this with Fedora 19.

Comment 15 Robert Muil 2013-08-06 07:19:59 UTC
(sorry sent too early):
setroubleshoot package details: setroubleshoot-3.2.10-1.fc19.i686
uname -a: Linux cordis 3.10.4-300.fc19.i686 #1 SMP Tue Jul 30 12:03:53 UTC 2013 i686 i686 i386 GNU/Linux

Comment 16 cooloutac 2013-08-19 23:47:28 UTC
I also have this bug. 

# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

command not found in fedora 19.

Also is there way to only allow plugin-container  on a specific file only?

Thank you.

Rich.

Comment 17 anthony.s.hughes 2013-09-23 01:08:08 UTC
I just wanted to add a comment to anyone still experiencing this.

As Michel alludes to in comment 12, setroubleshoot no longer includes policycoreutils-devel (required for audit2allow). If you want to use audit2allow you will need to install policycoreutils-devel explicitly:

> yum install policycoreutils-devel -y

By the way, this works for me as of Fedora 19. I hope this helps anyone encountering this issue in the future.

Comment 18 Daniel Walsh 2013-09-23 17:51:45 UTC
rpm -qf /usr/bin/audit2allow
policycoreutils-python-2.1.14-81.fc20.x86_64

Well we moved audit2allow into the -python package.


Note You need to log in before you can comment on or make changes to this bug.