Bug 879847 - Only 2 cores of AMD Phenom 945 quad-core activated.
Summary: Only 2 cores of AMD Phenom 945 quad-core activated.
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-24 20:13 UTC by Ralph Loader
Modified: 2012-11-28 23:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-28 23:43:37 UTC
Type: ---


Attachments (Terms of Use)
Output of acpidump (147.89 KB, text/plain)
2012-11-24 20:15 UTC, Ralph Loader
no flags Details
dmesg output (167.92 KB, text/x-log)
2012-11-27 23:52 UTC, Ralph Loader
no flags Details
lspci.txt (66.61 KB, text/plain)
2012-11-28 06:27 UTC, Ralph Loader
no flags Details
/proc/cpuinfo (1.76 KB, text/plain)
2012-11-28 06:28 UTC, Ralph Loader
no flags Details

Description Ralph Loader 2012-11-24 20:13:03 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
Build Identifier: 

With 3.6.7-5.fc18.x86_64, the kernel is only starting 2 of 4 cores:

$ egrep 'processor|model name' /proc/cpuinfo 
processor	: 0
model name	: AMD Phenom(tm) II X4 945 Processor
processor	: 1
model name	: AMD Phenom(tm) II X4 945 Processor

In the past, the kernel was correctly starting all 4 cores.

I'll attach acpidump output.

This kernel boot log message might or might not be relevant:

Nov 25 07:53:48 i kernel: setup_percpu: NR_CPUS:128 nr_cpumask_bits:128 nr_cpu_ids:4 nr_node_ids:1


Reproducible: Always

Steps to Reproduce:
1.  Boot fedora 18.
2.  cat /proc/cpuinfo
Actual Results:  
2 cores are running

Expected Results:  
4 cores should be running

Comment 1 Ralph Loader 2012-11-24 20:15:06 UTC
Created attachment 651220 [details]
Output of acpidump

Output of acpidump

Comment 2 Dave Jones 2012-11-27 19:46:30 UTC
can you attach the output of dmesg please.

Comment 3 Ralph Loader 2012-11-27 23:52:34 UTC
Created attachment 653203 [details]
dmesg output

First 1k lines of dmesg output (I'm assuming post-boot messages are irrelevant & have trimmed the file.  Let me know if my assumption is wrong).

Comment 4 Jacob Shin 2012-11-28 05:07:59 UTC
Hi,

Ralph,

Could you also attach:

1. The full output of:
   $ cat /proc/cpuinfo

2. And as root, the output of:
   $ lspci -s 0:18.* -xxxx

please ?

Thanks!

Comment 5 Jacob Shin 2012-11-28 05:12:23 UTC
Oh, and I also forgot to ask ..

Could you go through your BIOS options and make sure that there aren't any obvious things like "downcore" or "disable core" that is set? Just in case.

Thanks!

Comment 6 Ralph Loader 2012-11-28 06:27:37 UTC
Created attachment 653296 [details]
lspci.txt

Output of lspci -s 0:18.* -xxxx

Comment 7 Ralph Loader 2012-11-28 06:28:45 UTC
Created attachment 653309 [details]
/proc/cpuinfo

Comment 8 Ralph Loader 2012-11-28 06:58:37 UTC
Rebooted yet again to look through BIOS options.  Did not find any relevant.

Rebooted in Linux.

All 4 cores back.

WTF!  Your guess is probably better than mine.

Unless the information attached above contains a smoking gun, feel free to close as 'cannot reproduce'... if it reoccurs, I'll reopen...

Comment 9 Jacob Shin 2012-11-28 17:56:02 UTC
Weird..

Yes, in one of the CPU PCI configuration registers:

> 00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
...
> 190: 0c 00 00 00 00 00 00 00 00 04 78 00 00 00 00 00
       ^^

Bit 2 and 3 are set, which disables core 2 and 3. This is (was?) set by the BIOS.

If you see all 4 cores now, run the lspci command again, and see if those bits are clear now .. you should see 00.

Not really sure why it was set and now it's clear, and why your BIOS decided to change it's mind after reboot.

Thanks!

-Jacob

Comment 10 Ralph Loader 2012-11-28 23:43:37 UTC
Ok, the evidence is that this is nothing to do with fedora and everything to do with some buggy lump of closed source bios.

Closing.


Note You need to log in before you can comment on or make changes to this bug.