Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 879883 - [abrt] openbox-3.5.0-6.fc17: re.py:151:sub:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 28: ordinal not in range(128)
Summary: [abrt] openbox-3.5.0-6.fc17: re.py:151:sub:UnicodeDecodeError: 'ascii' codec ...
Keywords:
Status: CLOSED DUPLICATE of bug 874633
Alias: None
Product: Fedora
Classification: Fedora
Component: openbox
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b294f522cf5e7d21d9fb095409a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-25 04:37 UTC by Claudiomar Rodrigues
Modified: 2012-11-26 14:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-26 14:27:11 UTC
Type: ---


Attachments (Terms of Use)
File: environ (2.26 KB, text/plain)
2012-11-25 04:37 UTC, Claudiomar Rodrigues
no flags Details
File: dso_list (33 bytes, text/plain)
2012-11-25 04:37 UTC, Claudiomar Rodrigues
no flags Details
File: executable (29 bytes, text/plain)
2012-11-25 04:37 UTC, Claudiomar Rodrigues
no flags Details
File: smolt_data (2.82 KB, text/plain)
2012-11-25 04:37 UTC, Claudiomar Rodrigues
no flags Details
File: core_backtrace (342 bytes, text/plain)
2012-11-25 04:37 UTC, Claudiomar Rodrigues
no flags Details

Description Claudiomar Rodrigues 2012-11-25 04:37:14 UTC
Version-Release number of selected component:
openbox-3.5.0-6.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python /usr/libexec/openbox-xdg-menu applications
kernel:         3.6.7-4.fc17.x86_64

backtrace:
:re.py:151:sub:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 28: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/libexec/openbox-xdg-menu", line 101, in <module>
:    map(walk_menu, menu.getEntries())
:  File "/usr/libexec/openbox-xdg-menu", line 67, in walk_menu
:    map(walk_menu, entry.getEntries())
:  File "/usr/libexec/openbox-xdg-menu", line 73, in walk_menu
:    command = re.sub(' -caption "%c"| -caption %c', ' -caption "%s"' % entry_name(entry.DesktopEntry), entry.DesktopEntry.getExec())
:  File "/usr/lib64/python2.7/re.py", line 151, in sub
:    return _compile(pattern, flags).sub(repl, string, count)
:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 28: ordinal not in range(128)
:
:Local variables in innermost frame:
:count: 0
:pattern: ' -caption "%c"| -caption %c'
:repl: ' -caption "Mistura da exposi\xc3\xa7\xc3\xa3o"'
:flags: 0
:string: u'expoblending %i -caption "%c" %U'

Comment 1 Claudiomar Rodrigues 2012-11-25 04:37:17 UTC
Created attachment 651371 [details]
File: environ

Comment 2 Claudiomar Rodrigues 2012-11-25 04:37:19 UTC
Created attachment 651372 [details]
File: dso_list

Comment 3 Claudiomar Rodrigues 2012-11-25 04:37:21 UTC
Created attachment 651373 [details]
File: executable

Comment 4 Claudiomar Rodrigues 2012-11-25 04:37:23 UTC
Created attachment 651374 [details]
File: smolt_data

Comment 5 Claudiomar Rodrigues 2012-11-25 04:37:26 UTC
Created attachment 651375 [details]
File: core_backtrace

Comment 6 Miroslav Lichvar 2012-11-26 14:27:11 UTC

*** This bug has been marked as a duplicate of bug 874633 ***


Note You need to log in before you can comment on or make changes to this bug.