Bug 879917 - [abrt] irqbalance-1.0.3-6.fc17: g_list_first: Process /usr/sbin/irqbalance was killed by signal 11 (SIGSEGV)
[abrt] irqbalance-1.0.3-6.fc17: g_list_first: Process /usr/sbin/irqbalance wa...
Status: CLOSED DUPLICATE of bug 859572
Product: Fedora
Classification: Fedora
Component: irqbalance (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Holasek
Fedora Extras Quality Assurance
abrt_hash:2214e417e97d13e03c298cf91a4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-25 07:33 EST by Romanov Denis
Modified: 2016-10-04 00:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 11:57:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (608 bytes, text/plain)
2012-11-25 07:33 EST, Romanov Denis
no flags Details
File: environ (151 bytes, text/plain)
2012-11-25 07:33 EST, Romanov Denis
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-25 07:33 EST, Romanov Denis
no flags Details
File: cgroup (166 bytes, text/plain)
2012-11-25 07:33 EST, Romanov Denis
no flags Details
File: smolt_data (3.50 KB, text/plain)
2012-11-25 07:33 EST, Romanov Denis
no flags Details

  None (edit)
Description Romanov Denis 2012-11-25 07:33:29 EST
Version-Release number of selected component:
irqbalance-1.0.3-6.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/sbin/irqbalance
crash_function: g_list_first
kernel:         3.6.7-4.fc17.i686.PAE

backtrace:
:[New LWP 692]
:[Thread debugging using libthread_db enabled]
:Using host libthread_db library "/lib/libthread_db.so.1".
:Core was generated by `/usr/sbin/irqbalance'.
:Program terminated with signal 11, Segmentation fault.
:#0  g_list_first (list=0x1) at glist.c:840
:840	      while (list->prev)
:
:Thread 1 (Thread 0xb7786700 (LWP 692)):
:#0  g_list_first (list=0x1) at glist.c:840
:No locals.
:#1  0x0804b2b8 in for_each_object (data=0x0, cb=0x804b2a0 <clear_obj_stats>, list=<optimized out>) at irqbalance.h:121
:        entry = <optimized out>
:        next = <optimized out>
:#2  clear_obj_stats (d=0x80cfd28, data=data@entry=0x0) at cputree.c:318
:No locals.
:#3  0x0804b2d5 in for_each_object (data=0x0, cb=0x804b2a0 <clear_obj_stats>, list=<optimized out>) at irqbalance.h:124
:        entry = <optimized out>
:        next = 0x80c42c0
:#4  clear_obj_stats (d=0x80cc880, data=data@entry=0x0) at cputree.c:318
:No locals.
:#5  0x0804b2d5 in for_each_object (data=0x0, cb=0x804b2a0 <clear_obj_stats>, list=<optimized out>) at irqbalance.h:124
:        entry = <optimized out>
:        next = 0x80c6230
:#6  clear_obj_stats (d=0x80511c0, data=data@entry=0x0) at cputree.c:318
:No locals.
:#7  0x0804b475 in for_each_object (data=0x0, cb=0x804b2a0 <clear_obj_stats>, list=<optimized out>) at irqbalance.h:124
:        entry = <optimized out>
:        next = 0x0
:#8  clear_work_stats () at cputree.c:329
:No locals.
:#9  0x0804941c in main (argc=1, argv=0xbfc52dc4) at irqbalance.c:291
:        action = {__sigaction_handler = {sa_handler = 0x804bf20 <handler>, sa_sigaction = 0x804bf20 <handler>}, sa_mask = {__val = {0 <repeats 32 times>}}, sa_flags = 0, sa_restorer = 0x42b71f4d <__cxa_atexit+29>}
:From        To          Syms Read   Shared Object Library
:0x42f10e20  0x42f12b04  Yes         /lib/libcap-ng.so.0
:0x42f5cc50  0x42ffcb24  Yes         /lib/libglib-2.0.so.0
:0x42d24470  0x42d3e6d8  Yes         /lib/libm.so.6
:0x42d61e90  0x42d65f04  Yes         /lib/libnuma.so.1
:0x42b56f20  0x42c96fec  Yes         /lib/libc.so.6
:0x42b18850  0x42b30e87  Yes         /lib/ld-linux.so.2
:0x42d046a0  0x42d0fe60  Yes         /lib/libpthread.so.0
:0x42d51920  0x42d5543c  Yes         /lib/librt.so.1
:$1 = 0x0
:$2 = 0x0
:eax            0x1	1
:ecx            0x0	0
:edx            0x0	0
:ebx            0x80c42c0	135021248
:esp            0xbfc52bcc	0xbfc52bcc
:ebp            0xbfc52d28	0xbfc52d28
:esi            0x80cfd28	135068968
:edi            0x0	0
:eip            0x42f8bfd2	0x42f8bfd2 <g_list_first+18>
:eflags         0x10202	[ IF RF ]
:cs             0x73	115
:ss             0x7b	123
:ds             0x7b	123
:es             0x7b	123
:fs             0x0	0
:gs             0x33	51
:Dump of assembler code for function g_list_first:
:   0x42f8bfc0 <+0>:	mov    0x4(%esp),%eax
:   0x42f8bfc4 <+4>:	test   %eax,%eax
:   0x42f8bfc6 <+6>:	jne    0x42f8bfd2 <g_list_first+18>
:   0x42f8bfc8 <+8>:	jmp    0x42f8bfda <g_list_first+26>
:   0x42f8bfca <+10>:	lea    0x0(%esi),%esi
:   0x42f8bfd0 <+16>:	lea    (%edx),%eax
:=> 0x42f8bfd2 <+18>:	mov    0x8(%eax),%edx
:   0x42f8bfd5 <+21>:	test   %edx,%edx
:   0x42f8bfd7 <+23>:	jne    0x42f8bfd0 <g_list_first+16>
:   0x42f8bfd9 <+25>:	ret    
:   0x42f8bfda <+26>:	ret    
:End of assembler dump.
Comment 1 Romanov Denis 2012-11-25 07:33:42 EST
Created attachment 651511 [details]
File: core_backtrace
Comment 2 Romanov Denis 2012-11-25 07:33:45 EST
Created attachment 651512 [details]
File: environ
Comment 3 Romanov Denis 2012-11-25 07:33:47 EST
Created attachment 651513 [details]
File: limits
Comment 4 Romanov Denis 2012-11-25 07:33:49 EST
Created attachment 651514 [details]
File: cgroup
Comment 5 Romanov Denis 2012-11-25 07:33:51 EST
Created attachment 651515 [details]
File: smolt_data
Comment 6 Petr Holasek 2013-01-21 11:57:17 EST

*** This bug has been marked as a duplicate of bug 859572 ***

Note You need to log in before you can comment on or make changes to this bug.