Bug 880054 - [ALL_LANG][SAM CLI] Unlocalized strings for permission module.
[ALL_LANG][SAM CLI] Unlocalized strings for permission module.
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-26 01:24 EST by Lijun Li
Modified: 2013-06-07 14:28 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:28:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-26 01:24:06 EST
Description of problem:
Unlocalized strings for permission module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
# headpin permission available_verbs -h
Usage:  headpin <options> permission available_verbs <options>

Options:
  -h, --help     show this help message and exit
  --org=ORG      name of organization e.g.: ACME_Corporation
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
  --scope=SCOPE  範囲別の表示結果にフィルターをかける
  -g             grep が使いやすい出力
  -v             詳細な構造化された出力
  -d DELIMITER   grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading    ヘッディングの出力を表示しません。出力を grep する場合に便利です。

# headpin -u admin -p admin permission available_verbs
----------------------------------------------------------------------------------------------
                                        利用可能な動詞

Scope           Available Verbs   
^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized                                                            
----------------------------------------------------------------------------------------------
activation_keys manage_all, read_all                                                          
all             なし                                                                          
environments    delete_systems, read_contents, update_systems, register_systems, read_systems 
organizations   register_systems, read_systems, delete_systems, update_systems, update, read  
providers       update, read                                                                  
roles           create, read, delete, update                                                  
users           create, read, delete, update                      
Actual results:

# headpin -u admin -p admin permission available_verbs --org=test --scope=activation_keys
----------------------------------------------------------------------------------------------
                  パーミッション範囲 activation_keys に使用できる動詞とタグ
----------------------------------------------------------------------------------------------

Scope           : activation_keys
^^^^^^^^^^^^Unlocalized
Available Verbs:
^^^^^^^^^^^^Unlocalized
    manage_all           (アクティベーションキーの管理)
    read_all             (アクティベーションキーの読み込み)
Available Tags:
^^^^^^^^^^^^Unlocalized
    なし


# headpin permission create -h
Usage:  headpin <options> permission create <options>

Options:
  -h, --help            show this help message and exit
  --user_role=USER_ROLE
                        ロール名 (必須)
  --name=NAME           パーミッション名 (必須)
  --description=DESC    パーミッションの詳細
  --org=ORG             name of organization e.g.: ACME_Corporation
  --scope=SCOPE         パーミッションの範囲 (必須)
  --verbs=VERBS         パーミッションの動詞
  --tags=TAGS           パーミッションのタグ
  --all_tags            use to set all tags
                         ^^^^^^^^^^^^^^^^^^Unlocalized
  -g                    grep が使いやすい出力
  -v                    詳細な構造化された出力
  -d DELIMITER          grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading           ヘッディングの出力を表示しません。出力を grep する場合に便利です。

# headpin -u admin -p admin permission create --user_role=test --name=test --scope=activation_keys
Validation failed: Name 組織スコープ内で一意である必要があります。
^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin permission create --user_role=test --name=testqf --scope=environments --verbs=test
Validation failed: Invalid verb 'test'. Verbs for resource type 'environments' can be one of 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
read_systems, update_systems, delete_systems, read_contents, register_systems


# headpin -u admin -p admin permission create --user_role=test --name=testqq --scope=all --verbs=test
Validation failed: Cannot specify a verb if all_verbs is selected., Invalid verb 'test'. Verbs for resource type 'all' can be one of 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin permission create --user_role=test --name=testqq --scope=activation_keys --verbs=test
Validation failed: Invalid verb 'test'. Verbs for resource type 'activation_keys' can be one of manage_all, read_all
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin permission create --user_role=test --name=testqq --scope=organizations --verbs=test
Validation failed: Invalid verb 'test'. Verbs for resource type 'organizations' can be one of read_systems, read, update, create, update_systems, delete_systems, register_systems, delete
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin permission create --user_role=test --name=testqq --scope=providers --verbs=test
Validation failed: Invalid verb 'test'. Verbs for resource type 'providers' can be one of read, update
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin permission create --user_role=test --name=testqf --scope=environments --verbs=read_systems --tags=Library --all_tags
Can not specify a set of tags and use --all_tags
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin permission list --user_role=test
----------------------------------------------------------------------------------------------
                                      パーミッション一覧

Id Name   Scope        Verbs             Tags 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
----------------------------------------------------------------------------------------------
26 testqg read_systems  
         
Actual results:
Unlocalized strings for permission module.

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:54 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Noriko Mizumoto 2012-12-13 19:57:10 EST
confirmed for ja-JP
Comment 3 Sam Friedmann 2012-12-13 22:48:18 EST
Confirmed for fr-FR.
Comment 4 Hedda Peters 2012-12-13 22:50:05 EST
confirmed for de-DE
Comment 5 Eunju, Kim 2012-12-13 23:23:43 EST
confirmed for ko-KR
Comment 6 Tom McKay 2012-12-18 09:12:03 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 8 Bryan Kearney 2013-06-07 14:20:13 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 9 Bryan Kearney 2013-06-07 14:28:35 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.