Bug 880084 - /usr/bin/zforce does not work
/usr/bin/zforce does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gzip (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: pstodulk
Vaclav Danek
: EasyFix, FastFix, Patch
Depends On: 880081
Blocks: 1254457 1356044
  Show dependency treegraph
 
Reported: 2012-11-26 03:07 EST by manuel wolfshant
Modified: 2017-03-21 06:00 EDT (History)
4 users (show)

See Also:
Fixed In Version: gzip-1.3.12-23.el6
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: 880081
: 1382054 (view as bug list)
Environment:
Last Closed: 2017-03-21 06:00:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
easy-patch (431 bytes, patch)
2014-08-04 07:33 EDT, pstodulk
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 6096 None None None Never

  None (edit)
Description manuel wolfshant 2012-11-26 03:07:52 EST
+++ This bug was initially created as a clone of Bug #880081 +++

Description of problem:
/usr/bin/zforce fails to identify and rename valid gzipped files

Version-Release number of selected component (if applicable):

gzip-1.3.12-18.el6

How reproducible:
always

Steps to Reproduce:
1.	touch /tmp/test
2. gzip /tmp/test
3. mv /tmp/test.gz /tmp/test
4. zforce /tmp/test
  
Actual results:
Nothing happens

Expected results:
/tmp/test should be renamed to /tmp/test.gz

Additional info:

The /usr/bin/zforce utility is a script. Line 61

if gzip -l < "$i" 2>/dev/null | grep '^compressed' > /dev/null; then

is incorrect. The output of gzip -l /tmp/file (see above) is

         compressed uncompressed ratio uncompressed_name
                 25 0 0.0% /tmp/file

so '^compressed' fails because of the spaces printed in front of "compressed"
Comment 2 RHEL Product and Program Management 2013-10-13 20:14:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 pstodulk 2014-08-04 07:33:08 EDT
Created attachment 923846 [details]
easy-patch

edited regexp in origin patch
Comment 4 pstodulk 2014-08-04 07:35:39 EDT
I think this should be fast-track.
Comment 7 pstodulk 2016-09-30 05:23:41 EDT
No doc needed. Just zforce will not work, which previously didn't.
Comment 9 pstodulk 2016-10-05 11:36:01 EDT
(In reply to pstodulk from comment #7)
> No doc needed. Just zforce will not work, which previously didn't.

Of course, it will work now :-)
Comment 12 errata-xmlrpc 2017-03-21 06:00:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0639.html

Note You need to log in before you can comment on or make changes to this bug.