Bug 880090 - Cannot install windows 8 x86 with 0x0000005D error with cpu64-rhel6
Cannot install windows 8 x86 with 0x0000005D error with cpu64-rhel6
Status: CLOSED DUPLICATE of bug 821741
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 03:29 EST by Geyang Kong
Modified: 2013-08-04 23:45 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 12:44:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geyang Kong 2012-11-26 03:29:15 EST
Description of problem:
Cannot install windows 8 x86 with 0x0000005D error with cpu64-rhel6

How reproducible:
100%

Build info:
kernel-2.6.32-343.el6.x86_64
qemu-kvm-0.12.1.2-2.335.el6.x86_64

Steps to Reproduce:
1. Run /usr/libexec/qemu-kvm -cpu cpu64-rhel6 -m 2G -drive file=/var/lib/libvirt/images/T2.img -drive file=/root/Downloads/en_windows_8_enterprise_x86_dvd_917587.iso,media=cdrom,id=cdrom,if=none -device ide-drive,drive=cdrom,bootindex=1
  
Actual results:
1. Guest cannot be installed with error 0x0000005D

Expected results:
1. Guest could be installed normally

Additional info:
1. This error cannot be reproduced by qemu-kvm-0.12.1.2-2.316.el6.x86_64
2. This issue caused another issue: guest created by libvirt cannot be started with 0x0000005D error.
Comment 1 Geyang Kong 2012-11-26 03:41:10 EST
Since if user create a guest through virt-manager, normally they will just follow the wizard. But in this scenario, libvirt will not send -cpu host to qemu-kvm, then user will be certain to hit this issue. So I think qemu-kvm-0.12.1.2-2.316.el6.x86_64 is a better solution.
Comment 4 Sibiao Luo 2012-11-26 04:54:00 EST
Hi all,

   I have tested this issue to narrow down the range and check that from the qemu-kvm-0.12.1.2-2.320 cause regression. and i also tried other cpu model(SandyBridge & Opteron_G2), they can hit this issue on qemu-kvm-0.12.1.2-2.337.

qemu-kvm-0.12.1.2-2.337 + SandyBridge / Opteron_G2 -------> fail
qemu-kvm-0.12.1.2-2.330 + SandyBridge -------> fail
qemu-kvm-0.12.1.2-2.321 + SandyBridge -------> fail
qemu-kvm-0.12.1.2-2.320 + SandyBridge -------> fail
qemu-kvm-0.12.1.2-2.319 + SandyBridge -------> pass
qemu-kvm-0.12.1.2-2.318 + SandyBridge -------> pass
qemu-kvm-0.12.1.2-2.316 + SandyBridge -------> pass

Best Regards.
sluo
Comment 5 juzhang 2012-11-26 05:09:53 EST
Marked qa+ first even we do not fully support win8 on rhel6.4.
Comment 7 Eduardo Habkost 2012-11-27 12:25:02 EST
I could reproduce the issue using qemu-kvm-0.12.1.2-2.316.el6.x86_64, running kernel 2.6.32-279.el6.x86_64 on the host, so it doesn't seem to be a regression.
Comment 8 Eduardo Habkost 2012-11-27 12:44:19 EST
Please try to reproduce the bug using the latest 6.3.z packages, to confirm it is not a regression.

It happens to work if using qemu-kvm-0.12.1.2-2.316.el6.x86_64 on a newer kernel, because that version of qemu-kvm has a bug that makes it (incorrectly) enable the SEP feature unconditionally (see bug 745717), and that bug is visible only if using a newer kernel (that has the kernel bug 821463 fixed).

On 6.3, SEP was never enabled by default, and -2.320.el6 fixes bug 745717 by keeping SEP disabled.

To work around this problem, you can use "-cpu <model>,+sep" in the qemu command-line.

We have a bug for enabling SEP, already. See bug 821741.

*** This bug has been marked as a duplicate of bug 821741 ***

Note You need to log in before you can comment on or make changes to this bug.