Bug 880104 - mysqld crash every night
Summary: mysqld crash every night
Keywords:
Status: CLOSED DUPLICATE of bug 842052
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mysql
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tom Lane
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-26 09:28 UTC by Levente Farkas
Modified: 2013-04-02 07:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-02 07:46:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Levente Farkas 2012-11-26 09:28:10 UTC
mysql-5.1.66-1.el6_3.x86_64 crash every night here is the upstream bug i report:
http://bugs.mysql.com/bug.php?id=67707

with this in the log:
---------------------------------------
Version: '5.1.66-log'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  Source distribution
01:05:14 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

key_buffer_size=268435456
read_buffer_size=1048576
max_used_connections=15
max_threads=151
thread_count=8
connection_count=8
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 572962 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x19cab00
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7f399c307d98 thread_stack 0x40000
/usr/libexec/mysqld(my_print_stacktrace+0x29) [0x84dfe9]
/usr/libexec/mysqld(handle_fatal_signal+0x483) [0x6a2683]
/lib64/libpthread.so.0() [0x3e2020f500]
/lib64/libc.so.6(memcpy+0x15b) [0x3e1fa891ab]
/usr/libexec/mysqld(String::copy(char const*, unsigned int, charset_info_st*)+0x91) [0x5b8d01]
/usr/libexec/mysqld(String::copy(char const*, unsigned int, charset_info_st*, charset_info_st*, unsigned int*)+0xfa) [0x5b8e0a]
/usr/libexec/mysqld() [0x6c19cc]
/usr/libexec/mysqld() [0x6c1e13]
/usr/libexec/mysqld() [0x6c0794]
/usr/libexec/mysqld(get_all_tables(THD*, TABLE_LIST*, Item*)+0x147) [0x6c9ac7]
/usr/libexec/mysqld(get_schema_tables_result(JOIN*, enum_schema_table_state)+0x1f7) [0x6b9fe7]
/usr/libexec/mysqld(JOIN::exec()+0x4ed) [0x632e8d]
/usr/libexec/mysqld(mysql_select(THD*, Item***, TABLE_LIST*, unsigned int, List<Item>&, Item*, unsigned int, st_order*, st_order*, Item*, st_order*, unsigned long long, select_result*, st_select_lex_unit*, st_select_lex*)+0x15c) [0x62f3ac]
/usr/libexec/mysqld(handle_select(THD*, st_lex*, select_result*, unsigned long)+0x174) [0x634b24]
/usr/libexec/mysqld() [0x5c851a]
/usr/libexec/mysqld(mysql_execute_command(THD*)+0x4ce) [0x5c955e]
/usr/libexec/mysqld(mysql_parse(THD*, char*, unsigned int, char const**)+0x2d3) [0x5ceaf3]
/usr/libexec/mysqld(dispatch_command(enum_server_command, THD*, char*, unsigned int)+0xd15) [0x5d0b95]
/usr/libexec/mysqld(do_command(THD*)+0xea) [0x5d16ea]
/usr/libexec/mysqld(handle_one_connection+0x23e) [0x5c49ce]
/lib64/libpthread.so.0() [0x3e20207851]
/lib64/libc.so.6(clone+0x6d) [0x3e1fae811d]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (19c77d0): SHOW FIELDS FROM `geo_all_region`
Connection ID (thread ID): 2277
Status: NOT_KILLED

The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
121126 02:05:15 mysqld_safe Number of processes running now: 0
121126 02:05:15 mysqld_safe mysqld restarted
121126  2:05:47  InnoDB: Initializing buffer pool, size = 8.0M
121126  2:05:47  InnoDB: Completed initialization of buffer pool
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
121126  2:05:47  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Last MySQL binlog file position 0 34351046, file name ./mysql-bin.000152
121126  2:05:49  InnoDB: Started; log sequence number 1 222166831
121126  2:05:49 [Note] Recovering after a crash using mysql-bin
121126  2:05:52 [Note] Starting crash recovery...
121126  2:05:52 [Note] Crash recovery finished.
121126  2:05:52 [Note] Event Scheduler: Loaded 0 events
121126  2:05:52 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.1.66-log'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  Source distribution
---------------------------------------

Comment 2 Honza Horak 2012-11-27 07:37:38 UTC
Thanks for reporting. The backtrace looks very similar to the one in bug #842052 you've reported already and we have a fix for. It seems to me like some backup is being preformed using mysqldump during the night. Can you confirm this is the same bug?
http://bugs.mysql.com/bug.php?id=65971

Comment 3 Levente Farkas 2012-11-27 11:41:11 UTC
may be you've got right. i rebuild install and test the patched version a for a few days.

Comment 4 Honza Horak 2013-03-29 10:42:39 UTC
Levente, any news about testing this bug with patched version?

Comment 5 Levente Farkas 2013-03-29 14:44:55 UTC
the patched version works perfectly.

Comment 6 Honza Horak 2013-04-02 07:46:11 UTC
Thanks, so I'm closing this one as a duplicate of #842052.

*** This bug has been marked as a duplicate of bug 842052 ***


Note You need to log in before you can comment on or make changes to this bug.