Bug 880131 - [ALL_LANG][SAM CLI] Unlocalized strings for activation_key module
[ALL_LANG][SAM CLI] Unlocalized strings for activation_key module
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-26 05:34 EST by Lijun Li
Modified: 2013-06-07 14:28 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:28:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-26 05:34:15 EST
Description of problem:
Unlocalized strings for activation_key module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
# headpin activation_key create -h
Usage:  headpin <options> activation_key create <options>

Options:
  -h, --help            show this help message and exit
  --name=NAME           アクティベーションキーの名前 (必須)
  --org=ORG             name of organization e.g.: ACME_Corporation (required)
  --environment=ENVIRONMENT
                        environment name e.g.: production (required)
                        ^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin activation_key create --name=test --environment=test --org=test
Validation failed: Name has already been taken
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin activation_key create --name=testqc --environment=test --org=test --description=test --template=
Invalid resource type 'system_templates'. Resource Types can be one of 'users, providers, environments, roles, all, activation_keys, organizations'
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin activation_key create --name=testqe --environment=test --org=test --description=test --limit=
Usage:  headpin <options> activation_key create <options>

headpin: error: option --limit: invalid integer value: ''
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin activation_key info --name= --org=
Couldn't find organization 'activation_keys'
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin activation_key info --name=test --org=test
----------------------------------------------------------------------------------
                           アクティベーションキーの情報
----------------------------------------------------------------------------------

Id                 : 9
Name               : test
Description:
    None
Usage Limit        : unlimited
Environment Id     : 42
System Template Id : None
Pools:
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
    [ 8ac28a8e3b273ec5013b3bf805dc03c4 ]



# headpin -u admin -p admin activation_key list --org=test --environment=test
----------------------------------------------------------------------------------
                           アクティベーションキーの一覧

Id Name   Description 使用方法     Environment Id System Template Id 
^^^^^^^^^^^^^^^^^^^^^^^Unlocalized ^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
----------------------------------------------------------------------------------
11 testqe test        0/1      42             None               


# headpin -u admin -p admin activation_key update --name=test --org=test --new_name=
Validation failed: Name must contain at least 1 character, Name can't be blank
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin activation_key update --name=test --org=test --new_name=??
Validation failed: Name cannot contain characters other than alpha numerals, space,'_', '-'.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin activation_key update --name=test --org=test --new_name=test --environment=test --description=test --template=test
Invalid resource type 'system_templates'. Resource Types can be one of 'users, providers, environments, roles, all, activation_keys, organizations'
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin activation_key update --name=test --org=test --new_name=test --environment=test --description=test --limit=0
Validation failed: Usage limit must be higher than current usage (0) or unlimited
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


  
Actual results:
Unlocalized strings for activation_key module.

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:46 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Noriko Mizumoto 2012-12-13 20:20:01 EST
confirmed for ja-JP
Comment 3 Eunju, Kim 2012-12-13 23:48:38 EST
confirmed for ko-KR
Comment 4 Sam Friedmann 2012-12-14 00:39:47 EST
Confirmed for fr-FR.
Comment 5 Hedda Peters 2012-12-14 00:53:07 EST
similar result for de-DE, some strings mentioned above are localized though.
Comment 6 Hedda Peters 2012-12-14 01:34:40 EST
A couple for unlocalized strings for de-DE that I can't see mentioned yet:

[root@i18nsamtest ~]# headpin -u admin -p admin activation_key update --name=test --org=test --new_name=test --environment=test --description=test --add_subscription=
undefined method `with_indifferent_access' for #<Array:0x7fb4342617c8>

[root@i18nsamtest ~]# headpin -u admin -p admin activation_key update --name=test --org=test --new_name=test --environment=test --description=test --add_subscription=8ac28bb13ad9716e013ae36c76010240
Pool with id 8ac28bb13ad9716e013ae36c76010240 could not be found.
Comment 7 Tom McKay 2012-12-18 09:12:10 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 9 Bryan Kearney 2013-06-07 14:19:49 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 10 Bryan Kearney 2013-06-07 14:28:05 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.