Bug 880152 - qemu-kvm should emulate video device by default
qemu-kvm should emulate video device by default
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 06:26 EST by juzhang
Modified: 2014-06-17 23:19 EDT (History)
7 users (show)

See Also:
Fixed In Version: qemu-kvm-1.2.0-21.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:12:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description juzhang 2012-11-26 06:26:04 EST
Description of problem:
Boot guest with /usr/libexec/qemu-kvm -monitor stdio, the guest can not be booted with error Could not initialize SDL(No available video device) - exiting

Version-Release number of selected component (if applicable):
qemu-kvm-1.2.0-20.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot guest /usr/libexec/qemu-kvm -monitor stdio
2.
3.
  
Actual results:
Could not initialize SDL(No available video device) - exiting

Expected results:
qemu-kvm should emulated video device by default

Additional info:
Tested on  rhel6.4 qemu-kvm(qemu-kvm-0.12.1.2-2.334.el6.x86_64)

Result
/usr/libexec/qemu-kvm -monitor stdio
VNC server running on `::1:5900'
QEMU 0.12.1 monitor - type 'help' for more information
(qemu)
Comment 1 Gerd Hoffmann 2012-11-28 03:21:57 EST
Packaging bug, please build with --disable-sdl.
Comment 2 Michal Novotny 2012-11-28 04:13:00 EST
(In reply to comment #0)
> Description of problem:
> Boot guest with /usr/libexec/qemu-kvm -monitor stdio, the guest can not be
> booted with error Could not initialize SDL(No available video device) -
> exiting
> 
> Version-Release number of selected component (if applicable):
> qemu-kvm-1.2.0-20.el7.x86_64
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1.boot guest /usr/libexec/qemu-kvm -monitor stdio
> 2.
> 3.
>   
> Actual results:
> Could not initialize SDL(No available video device) - exiting
> 
> Expected results:
> qemu-kvm should emulated video device by default
> 
> Additional info:
> Tested on  rhel6.4 qemu-kvm(qemu-kvm-0.12.1.2-2.334.el6.x86_64)

Does it mean that it also affects RHEL-6.4 and not just RHEL-7?

Michal
Comment 3 Amit Shah 2012-11-28 04:20:49 EST
Removing SDL was a deliberate choice, please don't re-enable it.

The orig. bug seems to be that -monitor stdio doesn't work.
Comment 4 juzhang 2012-11-28 04:22:27 EST
> Does it mean that it also affects RHEL-6.4 and not just RHEL-7?
> 
> Michal

Just RHEL-7 along. Hope RHEL7 behavors much closer RHEL not upstream.

Best Regards & Thanks,
Junyi
Comment 5 Michal Novotny 2012-11-28 06:23:47 EST
(In reply to comment #1)
> Packaging bug, please build with --disable-sdl.

Well, I've been able to fix it however I needed to remove the SDL from audio list too as it re-enabled SDL using the CONFIG_SDL=y again and it was failing. It took me some time to investigate however it's fixed in qemu-kvm-1.2.0-21.el7.

Michal
Comment 7 mazhang 2014-01-20 21:45:33 EST
The package qemu-kvm-1.2.0-20.el7.x86_64 is too old, can not found it in brew.

Update to qemu-kvm-1.5.3-38.el7.x86_64 and test this bug.

Host:
RHEL-7.0-20131222.0
kernel-3.10.0-69.el7.x86_64
qemu-kvm-1.5.3-38.el7.x86_64

Steps:
/usr/libexec/qemu-kvm -monitor stdio

Result:
[root@amd-B95-8-1 ~]# /usr/libexec/qemu-kvm -monitor stdio
QEMU 1.5.3 monitor - type 'help' for more information
(qemu) VNC server running on `::1:5900'

(qemu) info vnc
Server:
     address: ::1:5900
        auth: none
Client: none
(qemu) info spice
Server: disabled
(qemu) 

The problem has gone, so this bug has been fixed.
Comment 9 Ludek Smid 2014-06-13 06:12:22 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.