Bug 880180 - RHEVM - Backend: Re-Initialize Data Center doesn't connect HSM hosts to new master
RHEVM - Backend: Re-Initialize Data Center doesn't connect HSM hosts to new m...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: 3.2.0
Assigned To: Liron Aravot
vvyazmin@redhat.com
storage
: Regression
Depends On: 902408
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-11-26 07:59 EST by Daniel Paikov
Modified: 2016-02-10 12:38 EST (History)
11 users (show)

See Also:
Fixed In Version: sf3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (156.51 KB, application/x-compressed-tar)
2012-11-26 07:59 EST, Daniel Paikov
no flags Details
SPM vdsm.log (632.83 KB, application/x-xz)
2012-11-28 05:49 EST, Daniel Paikov
no flags Details
HSM vdsm.log (598.88 KB, application/x-xz)
2012-11-28 05:50 EST, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2012-11-26 07:59:35 EST
Created attachment 651943 [details]
engine.log

* DC in Non Responsive or Maintenance status.
* Perform Re-Initialize Data Center.
* Engine only connects one host (future SPM) to the new master domain.
* Other hosts aren't connected and become Non Operational.
* (Auto Recovery successfully re-activates the Non Operational hosts).
Comment 3 Allon Mureinik 2012-11-28 04:52:11 EST
Regression was added since this worked in 3.0.
Comment 4 Daniel Paikov 2012-11-28 05:49:24 EST
Created attachment 653416 [details]
SPM vdsm.log
Comment 5 Daniel Paikov 2012-11-28 05:50:14 EST
Created attachment 653417 [details]
HSM vdsm.log
Comment 6 Liron Aravot 2012-12-05 11:24:46 EST
http://gerrit.ovirt.org/#/c/9748/
Comment 7 vvyazmin@redhat.com 2013-01-21 10:47:40 EST
Fail on iSCSI and FC environments

Failed on RHEVM 3.2 - SF03 environment 

RHEVM: rhevm-3.2.0-4.el6ev.noarch
VDSM: vdsm-4.10.2-3.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-13.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64
Comment 8 vvyazmin@redhat.com 2013-01-23 09:49:31 EST
Failed reproduce all steps (failed on iSCSI and FC environments). Block by BZ902408
Comment 9 vvyazmin@redhat.com 2013-01-27 05:16:33 EST
Verified on RHEVM 3.2 - SF04 environment (iSCSI and FC):

RHEVM: rhevm-3.2.0-5.el6ev.noarch
VDSM: vdsm-4.10.2-4.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-16.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64

Succeed Re-Initialize Data Center, but get an other exception during Re-Initialize action. Open a new bug BZ904724
Comment 10 Itamar Heim 2013-06-11 04:36:37 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:36:38 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:36:40 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 04:45:05 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.