This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 880216 - RHEVM-CLI: negative numbers wrapped as strings
RHEVM-CLI: negative numbers wrapped as strings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Michael Pasternak
Ilia Meerovich
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-11-26 09:19 EST by Ilia Meerovich
Modified: 2016-02-10 14:21 EST (History)
9 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
When setting a negative value for 'scheduling_policy-thresholds-low' the system did not recognize it as a number and generated the following error 'error: %d format: a number is required, not str'. This has been rectified so negative values can now be used.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:28:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ilia Meerovich 2012-11-26 09:19:47 EST
When I'm running:
update cluster RestCluster6  --data_center-id '79a850e5-459c-4305-86f2-9a0be4f3a447' --scheduling_policy-policy 'power_saving' --scheduling_policy-thresholds-high 60 --scheduling_policy-thresholds-duration 240 --scheduling_policy-thresholds-low -1 --cpu-id 'AMD Opteron G3'

I'm getting  "error: %d format: a number is required, not str".
This is incorrect error.


[imeerovi@imeerovi ART]$ rpm -qa | grep rhevm-cli
rhevm-cli-3.1.0.17-1.el6ev.noarch
Comment 1 Michael Pasternak 2012-12-16 04:17:41 EST
http://gerrit.ovirt.org/10100
Comment 2 Ilia Meerovich 2013-02-05 04:29:38 EST
[RHEVM shell (connected)]# update cluster Default --data_center-id 36e3e8ae-48f9-11e2-85c4-001a4a169715 --scheduling_policy-policy 'power_saving' --scheduling_policy-thresholds-high 60 --scheduling_policy-thresholds-duration 240 --scheduling_policy-thresholds-low -1 --cpu-id 'AMD Opteron G3'

error: 
status: 400
reason: Bad Request
detail: Both low and high CPU utilization thresholds must be defined when using power saving policy.

[RHEVM shell (connected)]# 


wrong error message (expected message should be related to wrong value of --scheduling_policy-thresholds-low)
Comment 3 Michael Pasternak 2013-02-05 04:43:59 EST
(In reply to comment #2)
> [RHEVM shell (connected)]# update cluster Default --data_center-id
> 36e3e8ae-48f9-11e2-85c4-001a4a169715 --scheduling_policy-policy
> 'power_saving' --scheduling_policy-thresholds-high 60
> --scheduling_policy-thresholds-duration 240
> --scheduling_policy-thresholds-low -1 --cpu-id 'AMD Opteron G3'
> 
> error: 
> status: 400
> reason: Bad Request
> detail: Both low and high CPU utilization thresholds must be defined when
> using power saving policy.
> 
> [RHEVM shell (connected)]# 
> 
> 
> wrong error message (expected message should be related to wrong value of
> --scheduling_policy-thresholds-low)

why do you think this is same bug & failed QA?, you can see backend error that you have to define both "low and high CPU utilization thresholds" while you defined only --scheduling_policy-thresholds-high!,

"scheduling_policy-thresholds-low -1" is illegal value from backend PoV, it's should be positive value,

also original error was "error: %d format: a number is required, not str"
Comment 4 Ilia Meerovich 2013-02-05 04:54:34 EST
Michael, as end use i don't know what is backend and what is frontend, i know that i'm using rhevm-shell and i cannot understand from this error whats wrong.
so from my point of view bug is still open
Comment 5 Michael Pasternak 2013-02-05 05:09:35 EST
(In reply to comment #4)
> Michael, as end use i don't know what is backend and what is frontend, i
> know that i'm using rhevm-shell and i cannot understand from this error
> whats wrong.
> so from my point of view bug is still open

This is not relevant what the backend is, you got very explicit error message
saying that you have to supply both high&low values, and since you provided low
value -1, it's illegal/not-ok from system PoV (if you want, you welcome to file BE bug on this for another error message), but since original bug was:

"error: %d format: a number is required, not str".

but since passing negative number (as is) worked, what is solved bug complaint, this bug cannot be open/failed-qa by definition.
Comment 6 Ilia Meerovich 2013-02-07 07:02:37 EST
will open BE bug for it
Comment 7 errata-xmlrpc 2013-06-10 16:28:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0890.html

Note You need to log in before you can comment on or make changes to this bug.