Bug 88023 - anaconda crashes during network install with kickstart: TypeError: bad magic in header
anaconda crashes during network install with kickstart: TypeError: bad magic ...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
http://vulcan.mse.jhu.edu/data/crash/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-04 14:00 EST by Elliot Metsger
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-07 11:33:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda trace dump. (49.33 KB, text/plain)
2003-04-04 14:01 EST, Elliot Metsger
no flags Details
HTTP access log showing that anaconda didn't check for disc1/RedHat/base/hdlist (687 bytes, text/plain)
2003-04-04 14:03 EST, Elliot Metsger
no flags Details
My (slightly modifed) kickstart file. (1.83 KB, text/plain)
2003-04-04 14:03 EST, Elliot Metsger
no flags Details
My (slightly modified) syslinux.cfg file that I use on my network boot disk. (825 bytes, text/plain)
2003-04-04 14:04 EST, Elliot Metsger
no flags Details
Patch to urlinstall.py (646 bytes, patch)
2003-04-04 23:10 EST, Elliot Metsger
no flags Details | Diff

  None (edit)
Description Elliot Metsger 2003-04-04 14:00:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I generated an 8.0 kickstart file using the 8.0 Kickstart Configurator 2.3.3.  I
modified the resulting kickstart file adding certain RPM groups and added a
%post section.  I put the kickstart file on a network boot floppy, and booted
with ks=floppy (ks file attached).

The machine boots fine, it uses method http.  Monitor is auto-probed fine.  It
retrieves netstg1.img successfully etc from boot server.  It loads the megaraid
driver (onboard raid) and the AIC scsi card driver and then anaconda crashes
producing a tracedump (file attached).  The last entry in the httpd log of the
bootserver is:
x.x.x.x - - [04/Apr/2003:13:40:08 -0500] "GET
/data/iso/mnt/redhat/8.0/RedHat/base/hdlist HTTP/1.0" 404 1044 "-"
"Python-urllib/1.15"

Since I am doing iso loopback mounts, it should check
<installbase>/RedHat/base/hdlist *and* <installbase>/disc1/RedHat/base/hdlist,
but it never does.  Anaconda crashes before it checks the second location. 

The bootserver is running RedHat 8.0.  It serves out installs via http, using
iso9660 loopback mounts.  I can verify that the http distribution works as I can
wget files from the install url from other machines.

The computer running the bootfloppy is a dell poweredge 4200, with scsi drives. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Create an 8.0 network boot floppy using dd.
2.  Remove snake.msg to make room for the ks.cfg file.
3.  Modify the syslinux.cfg file to boot with default ks=floppy (attached).
4.  Create a ks file with the Kickstart Configurator 2.3.3.  
5.  Modify the ks file to add custom RPM's
6.  Modify the ks file to add custom partitions
7.  Modify the ks file to add a %post section.
8.  Boot machine with floppy.
9. The crash.
    

Actual Results:  Recieved an "Exception Occurred" window with an anaconda traceback.
Saved the crash dump to floppy.

Expected Results:  Should have gone on to automatically configure partitions.

Additional info:

Relevant files attached, and present at URL above.
Comment 1 Elliot Metsger 2003-04-04 14:01:47 EST
Created attachment 90903 [details]
Anaconda trace dump.
Comment 2 Elliot Metsger 2003-04-04 14:03:10 EST
Created attachment 90904 [details]
HTTP access log showing that anaconda didn't check for disc1/RedHat/base/hdlist
Comment 3 Elliot Metsger 2003-04-04 14:03:36 EST
Created attachment 90905 [details]
My (slightly modifed) kickstart file.
Comment 4 Elliot Metsger 2003-04-04 14:04:06 EST
Created attachment 90906 [details]
My (slightly modified) syslinux.cfg file that I use on my network boot disk.
Comment 5 Michael Fulbright 2003-04-04 15:00:09 EST
What does the hierachy under:

http://vulcan/data/iso/mnt/redhat/8.0

look like?

I was able to do an installation using loopback mounted ISO images w/o problems.
Comment 6 Elliot Metsger 2003-04-04 15:08:18 EST
Here is the hierarchy:
[esm@sys02 8.0]$ pwd
/data/iso/mnt/redhat/8.0
[esm@sys02 8.0]$ ls
disc1  disc2  disc3
[esm@sys02 8.0]$

Did you use my kickstart file to do the install?  The question isn't whether the
iso/loopback mount will succeed - I've performed that sucessfully in the past. 
I don't think anaconda should be failing....
Comment 7 Elliot Metsger 2003-04-04 15:14:34 EST
FYI you should be able to browse the hierarchy for yourself:
http://vulcan.mse.jhu.edu/data/iso/mnt/redhat/8.0 (added the fqdn to the url)


Comment 8 Michael Fulbright 2003-04-04 16:29:27 EST
If you add '/disc1' to your kickstart install url spec does that help?

Admitedly I tested this with RHL 9, in which I seem to recall I may have fixed
an issue like this...
Comment 9 Elliot Metsger 2003-04-04 21:56:15 EST
No this did not fix the problem.

Have you looked at the attachements I've provided?  If you look at the http
access log you will see that there isn't an issue with finding netstg1.img nor
updates.img both which sit under disc1.  The installer doesn't know if I have
the redhat installation under <installbase> or if I have it under
<installbase>/disc1 so it tries both - that is built into the installer.  The
install performs fine if I don't use kickstart with the same install base of
/data/iso/mnt/redhat/8.0.

You also didn't answer my first question: did you try the install with *my*
kickstart file and have you looked at the trace dump at all?  

Elliot
Comment 10 Elliot Metsger 2003-04-04 23:10:17 EST
Created attachment 90920 [details]
Patch to urlinstall.py

This is a patch to /usr/lib/anaconda/urlinstall.py in diff -u format.  It
compiled successfully but I have yet to remake the netstg1.img file.  Will test
this weekend.
Comment 11 Elliot Metsger 2003-04-07 11:33:37 EDT
Ok, I feel stupid.  I've been using /data/iso/mnt/redhat/8.0 as my base url,
instead of /data/iso/mnt/redhat/8.0/disc1.  I didn't think I had to specify
/disc1, I thought it would auto-detect whether or not i was doing a cd
installation (based on the behavior of the installer when it tried retrieving
netstg1.img and update.img).  So the previous patch is bogus.  Less coffee and
more sleep would do me some good I think.  Thanks for your help!
Comment 12 Elliot Metsger 2003-04-07 11:34:58 EDT
> If you add '/disc1' to your kickstart install url spec does that help?

As an aside, I misunderstood what you meant by this comment, but now I do!

Thanks again,
Elliot

Note You need to log in before you can comment on or make changes to this bug.