Bug 880364 - Please update ogre platform to 1.8.1 version
Summary: Please update ogre platform to 1.8.1 version
Keywords:
Status: CLOSED DUPLICATE of bug 873353
Alias: None
Product: Fedora
Classification: Fedora
Component: ogre
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bruno Wolff III
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: rigsofrods
TreeView+ depends on / blocked
 
Reported: 2012-11-26 20:14 UTC by Pavel Alexeev
Modified: 2012-11-27 16:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-27 11:26:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Pavel Alexeev 2012-11-26 20:14:54 UTC
It is required for my rigsofrods package which under review.

Comment 1 Bruno Wolff III 2012-11-26 20:33:12 UTC
We aren't likely to do this for f17/f18 since it will break other packages.

I'd like to see 1.8.1 available for f19. Ember 0.7 should be out in time for this.

Once we have this working in f19, we could look at the impact of updating the packages that use ogre in previous releases of Fedora. Normally breaking library APIs/ABIs in released versions of Fedora is frowned upon. But getting a new package is a positive that could potentially make updating in previous releases the better way to go.

There is already a generic update Ogre ticket.

I think Martin has already done some looking at 1.8, but I am not sure where he's at now.

Comment 2 Martin Preisler 2012-11-27 11:26:16 UTC
It's not terribly difficult to package Ogre 1.8, the issue is that we break apps depending on Ogre 1.7 API.

Anybody is free to help with the Ogre 1.8 package at https://bitbucket.org/mpreisler/fedora-ogre18

Since there has already been one Ogre 1.8 request I think it's safe to mark this as duplicate.

*** This bug has been marked as a duplicate of bug 873353 ***

Comment 3 Pavel Alexeev 2012-11-27 16:18:33 UTC
Thanks for the answer guys. I think update it in Fedora 19 will be good enough. And sorry for duplicate, I follow it.


Note You need to log in before you can comment on or make changes to this bug.