Bug 880452 - unable to add Chinese to the ibus list using"Input method Selector"
unable to add Chinese to the ibus list using"Input method Selector"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 21:55 EST by lnie
Modified: 2013-06-14 02:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 02:41:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
error.png (769.94 KB, image/png)
2012-11-28 03:08 EST, lnie
no flags Details

  None (edit)
Description lnie 2012-11-26 21:55:03 EST
Description of problem:
I have make a successful default install with English,then I want to add Chinese to the ibus list ,but failed.

Version-Release number of selected component (if applicable):
f18 beta RC1 x86_64 

How reproducible:
100%

Steps to Reproduce:
1.make a default install with English and open the "Input method Selector"
2.click "reference"button,and add "intelligent Pinyin"to the list of"Input method"
3.close the "reference"and click"use ibus" to start the ibus,but failed,and there pop up an error message said:failed to change the input method. 
  
Actual results:


Expected results:


Additional info:
Comment 1 fujiwara 2012-11-27 22:32:46 EST
Which desktop do you use?
If you use gnome-shell, gnome-control-center can be used instead of ibus-setup.


(In reply to comment #0)
> 3.close the "reference"and click"use ibus" to start the ibus,but failed,and
> there pop up an error message said:failed to change the input method. 

I don't see such a error.
Are you able to attach the screenshot?

% gnome-screenshot -i
Comment 2 lnie 2012-11-28 03:07:49 EST
  
  Yeah,my desktop is gnome-shell.
  I know gnome-control-center can be used,however,I suppose that this bug will be  annoy for the users,as they are accustomed to using the ibus-setup.
Comment 3 lnie 2012-11-28 03:08:49 EST
Created attachment 653330 [details]
error.png
Comment 4 fujiwara 2012-12-06 04:54:03 EST
AFAIK, you tried to install the f18 again.
Are you still able to reproduce your problem?
Comment 5 lnie 2012-12-06 21:23:30 EST
yeah,this bug still occurs.
Comment 6 fujiwara 2012-12-06 21:58:00 EST
(In reply to comment #3)
> Created attachment 653330 [details]
> error.png

Reading your error, I think imsettings is not necessary in gnome-shell.
Did you install the latest im-chooser, imsettings, and imsettings-gnome ?

# yum install ibus im-chooser imsettings imsettings-gnome

or you could remove those.


Also you could check $HOME/.cache/imsettings/log
Comment 7 lnie 2012-12-06 22:23:15 EST
(In reply to comment #6)
> (In reply to comment #3)
> > Created attachment 653330 [details]
> > error.png
> 
> Reading your error, I think imsettings is not necessary in gnome-shell.
> Did you install the latest im-chooser, imsettings, and imsettings-gnome ?
> 
> # yum install ibus im-chooser imsettings imsettings-gnome
> 
> or you could remove those.
> 
> 
> Also you could check $HOME/.cache/imsettings/log

No,I have not install .
Comment 8 fujiwara 2013-06-14 02:41:22 EDT
gnome-control-center needs to be used instead.

Note You need to log in before you can comment on or make changes to this bug.