Bug 880458 - Failed to resume from S3 as a response for keyboard/mouse action when view guest with remote-viewer
Failed to resume from S3 as a response for keyboard/mouse action when view gu...
Status: CLOSED DUPLICATE of bug 870710
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 22:24 EST by Qunfang Zhang
Modified: 2012-11-26 22:42 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-26 22:42:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2012-11-26 22:24:56 EST
Description of problem:
We have feature in rhel6.3, to resume guest from S3 as a response for monitor/keyboard/mouse action. It works when view guest with vncviewer or spicec. But failed if view guest with remote-viewer.
Reference: Bug 789327 - [RFE] Resume VM from s3 as a response for monitor/keyboard/mouse action 

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-16.el6.x86_64
kernel-2.6.32-344.el6.x86_64
qemu-kvm-0.12.1.2-2.337.el6.x86_64
spice-server-0.12.0-4.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot a guest with spice and install qxl driver.
 /usr/libexec/qemu-kvm -boot menu=on -m 2G -smp 2,cores=2,sockets=1,threads=1 -M rhel6.4.0 -cpu SandyBridge -drive file=/home/win7-32-virtio.raw,format=raw,if=none,id=drive-ide0,cache=none,werror=stop,rerror=stop  -device virtio-blk-pci,bus=pci.0,addr=0x3,drive=drive-ide0,id=test0  -netdev tap,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=00:12:1a:21:62:02,bus=pci.0,addr=0x6,id=virtio-net-pci1 -uuid ac64c74a-a8d5-4c24-9839-fcc491439493 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection  -name win7-32 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x9  -chardev null,id=charchannel0,path=/tmp/qzhang-1,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=5,chardev=charchannel0,id=channel0,name=port-1 -chardev null,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel1,id=channel1,name=com.redhat.spice.0  -boot c -drive file=en_windows_7_ultimate_with_sp1_x86_dvd_619077.iso,if=none,werror=stop,rerror=stop,media=cdrom,id=drive-cdrom -device ide-drive,drive=drive-cdrom,id=cdrom -spice port=5930,disable-ticketing -vga qxl  -monitor stdio -drive file=/usr/share/virtio-win/virtio-win-1.5.4.vfd,if=none,id=drive-fdc0-0-0,readonly=on,format=raw -global isa-fdc.driveA=drive-fdc0-0-0 -global  PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0


2. Suspend guest to memory by clicking "start" -> the "arrowhead symbol beside shutdown button" -> "Sleep"

3. Resume guest by press keyboard or mouse.
  
Actual results:
No response after step 3.

Expected results:
Guest should be resume from s3 after step 3.

Additional info:
If view guest with vncviewer or spicec, no such problem.
Comment 2 Qunfang Zhang 2012-11-26 22:42:59 EST

*** This bug has been marked as a duplicate of bug 870710 ***

Note You need to log in before you can comment on or make changes to this bug.