Bug 880491 - Grub2 fails to add all alternative distributions
Grub2 fails to add all alternative distributions
Status: CLOSED DUPLICATE of bug 825236
Product: Fedora
Classification: Fedora
Component: os-prober (Show other bugs)
18
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Hedayat Vatankhah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 01:16 EST by Leslie Satenstein
Modified: 2012-12-03 03:05 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 03:05:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The original grub.cfg created by Fedora 18 Rc1 with btfrs as default file system (12.95 KB, text/plain)
2012-11-28 22:53 EST, Leslie Satenstein
no flags Details
The grub.cfg after Fedora 18 RC1 was installed. (17.55 KB, text/plain)
2012-11-28 22:56 EST, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2012-11-27 01:16:46 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Install Fedora 18 RC 1 from DVD.  On reboot, the grub menu does not show all other distributions.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Fedora 17 missing from the grub.cfg.

Expected results:
Expected F17 to be includedé

Additional info:
Logged into root and reran the grub2-mkconfig > /tmp/grub.cfg.
Verified that the /tmp/grub.cfg included the missing distributions. 
Replaced /boot/grub.cfg  and rebooted.

Note. For full inclusion with multi=boot, all alternate partitions should be mounted.
Comment 1 Mads Kiilerich 2012-11-27 06:19:17 EST
Please show the output from os-prober.

If possible then please also try it from the install dvd.

The problem is most likely caused by lvm/dm not being initialized correctly when running from the install dvd.
Comment 2 Hedayat Vatankhah 2012-11-27 13:13:00 EST
Please specify where the undetected distributions are located (partition type/file system type). I can think of two reasons for not detecting other OSes during installation:
1. OSes on file systems not supported in Anaconda
2. OSes on LVM partitions due to bug #825236 (in this case your bug will be duplicate of that bug).
Comment 3 Leslie Satenstein 2012-11-28 22:53:24 EST
Created attachment 653982 [details]
The original grub.cfg created by Fedora 18 Rc1 with btfrs as default file system
Comment 4 Leslie Satenstein 2012-11-28 22:56:32 EST
Created attachment 653983 [details]
The grub.cfg after Fedora 18 RC1 was installed.

This grub.cfg was created after I mounted the unmounted partitions. 
I used grub2-mkconfig

The file system is btfrs, the system is dual core 32bit (I can redo to 64bit if you need a 64bit version. 

The Intel dual core system has 3.5gig of ddr2. 

Anything else such as 

> *os-prober
> /dev/sdb6:Ubuntu 12.04.1 LTS (12.04):Ubuntu:linux
> /dev/mapper/vg_lesliedesktop-lv_root:Fedora release 17 (Beefy
> Miracle):Fedora:linux
> *

Can be provided.
Comment 5 Mads Kiilerich 2012-11-29 06:14:13 EST
Yeah, I'm quite sure that is bug #825236.

To confirm that please boot up on the install media and run 'os-prober' manually, perhaps on a ctrl+alt+Fsomething terminal.
Comment 6 Hedayat Vatankhah 2012-12-03 03:05:47 EST

*** This bug has been marked as a duplicate of bug 825236 ***

Note You need to log in before you can comment on or make changes to this bug.