Bug 880499 - webadmin: bookmark cannot be re-selected
webadmin: bookmark cannot be re-selected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Greg Padgett
Jiri Belka
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-11-27 02:36 EST by Yaniv Kaul
Modified: 2016-06-12 19:16 EDT (History)
12 users (show)

See Also:
Fixed In Version: sf4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10781 None None None Never
oVirt gerrit 10819 None None None Never

  None (edit)
Description Yaniv Kaul 2012-11-27 02:36:46 EST
Description of problem:


Version-Release number of selected component (if applicable):
SI24.4.

How reproducible:


Steps to Reproduce:
1. Select a bookmark (that has filter for the VMs tab).
2. Move to the 'Storage tab' - the search bookmark disappears, but the bookmark is still selected.
3. Try to re-select the bookmark - you can't.
  
Actual results:
The bookmark cannot be re-selected.

Expected results:
The bookmark is selected again.

Additional info:
Workaround: click on a different bookmark, then the bookmark you wished initially.
Regression; I' quite sure it's a regression from WPF, but don't have an environment to test this.
Comment 1 Einav Cohen 2012-11-27 09:21:22 EST
strange: (what seems to be) an identical problem has been solved almost a year ago as part of upstream bug 785754. Worth taking a look at the patch that (supposedly) solved it.
Comment 2 Greg Padgett 2013-01-15 09:20:14 EST
Merged, 2 patches:
Change-Id: I21e0f807f5855f17d3549468a6ccf182156f12bb
Change-Id: I25a9e721d8b7ccd982708eadf579e9eb229dedd5
Comment 3 Oded Ramraz 2013-01-24 10:34:18 EST
Verified according to steps to reproduce 

sf4
Comment 4 Itamar Heim 2013-06-11 04:36:17 EDT
3.2 has been released
Comment 5 Itamar Heim 2013-06-11 04:36:17 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 04:36:19 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 04:44:50 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.