Bug 880500 - 'ESC' should not cancel the translation editing
'ESC' should not cancel the translation editing
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI, Usability (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity high
: ---
: 2.0
Assigned To: Alex Eng
Sean Flanigan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 02:39 EST by Ding-Yi Chen
Modified: 2013-02-25 22:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121128-1124)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 729843
Environment:
Last Closed: 2013-02-25 22:46:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-11-27 02:39:35 EST
+++ This bug was initially created as a clone of Bug #729843 +++

Description of problem:

For Japanese, input process for a word is: 
 type in by sounds
 -> determine the ending of the word
 -> convert to Japanese (first candidate)
 -> show other candidates list (if first one is not right and mostly not right)
 -> choose right candidate from the list
 -> determine translation. 

Any stage, translator can go back if she wants. For
example, translator can return from 'show other candidates list' back to
'convert first candidate' by pressing 'ESC' key. However in zanata, if
translator accidentally press 'ESC' twice, entire input just simply is
cancelled. This hurts especially when translator lost lengthy translation.


Version-Release number of selected component (if applicable):
1.3

Additional info:

From noriko@redhat.com

--- Additional comment from David Mason on 2011-08-11 13:04:19 EST ---

Pushed to master and 1.4 branches

--- Additional comment from David Mason on 2011-08-11 16:14:46 EST ---

Also removed 'Esc' hint from tool tip of cancel button.

--- Additional comment from Ding-Yi Chen on 2011-09-06 14:08:04 EST ---

VERIFIED with Zanata version 1.4-SNAPSHOT (20110901-1705)

======================================================================
This bug is reproduceable in 2.0.

Since the expected behavior of the translation entry is act like a plain textarea, i.e., pressing Esc should not clean the textarea.

Ctrl-a and Backspace should be sufficiently fast to clean a textarea.

Version-Release number of selected component (if applicable):
Zanata version 2.0.3-SNAPSHOT (20121127-0017)

Steps to reproduce:
1. In translation editor, type something
2. Press "Esc"

Actual:
The text you type is canceled.

Expected:
Nothing changed
Comment 1 Alex Eng 2012-11-27 17:11:39 EST
The initial implementation for this functionality ('Esc' key to cancel changes and close editor ) was back in 1.4 
See https://bugzilla.redhat.com/show_bug.cgi?id=747157 

Since the behavior has been changed since 2.0. This implementation should be remove to work with new behavior of the editor.
Comment 2 Alex Eng 2012-11-27 17:25:04 EST
With removing of the "Esc" key to cancel changes, we need to find a keyboard shortcut for "Cancel changes". Any ideas?
Comment 3 Alex Eng 2012-11-27 18:51:13 EST
Removed 'Esc' key as cancel translation.
See https://github.com/zanata/zanata/commit/f1885cff1948f3630ef478f2b3ccd8d60b59ae0a
Comment 4 Sean Flanigan 2012-11-27 20:48:52 EST
The nearest surviving shortcut will be Ctrl-Z in an editor field, which can undo one text change at a time.  (Note that if you keep pressing it, it may undo changes which happened before the last save.)

If we bring back a shortcut for Cancel Changes in future, I think we should avoid the Esc key entirely, rather than providing an option to turn it on and off.

Note You need to log in before you can comment on or make changes to this bug.