Bug 880505 - munin-node: log rotation is skipped for permissions reasons
Summary: munin-node: log rotation is skipped for permissions reasons
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: munin
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-27 08:04 UTC by Adrian Reber
Modified: 2013-01-14 08:44 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-14 08:44:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Adrian Reber 2012-11-27 08:04:07 UTC
Description of problem:
see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=669230

same happened for the first time tonight for me on Fedora:

error: skipping "/var/log/munin/munin-node.log" because parent directory has insecure permissions (It's world writable or writable by group which is not "root") Set "su" directive in config file to tell logrotate which user/group should be used for rotation.


Version-Release number of selected component (if applicable):
munin-node-2.0.8-1.fc17.noarch

How reproducible:
happened tonight for the first time after updating to munin-node-2.0.8-1.fc17.noarch yesterday

Comment 1 Wolfgang Denk 2012-11-28 08:23:16 UTC
same here on all systems running munin-node-2.0.8-1.fc17.noarch

Comment 2 Lonni J Friedman 2012-12-02 20:22:23 UTC
/me too

Comment 3 Fedora Update System 2012-12-08 18:00:28 UTC
munin-2.0.9-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/munin-2.0.9-2.fc18

Comment 4 Fedora Update System 2012-12-08 18:01:51 UTC
munin-2.0.9-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.9-2.fc17

Comment 5 Fedora Update System 2012-12-08 18:04:12 UTC
munin-2.0.9-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-2.0.9-2.fc16

Comment 6 Fedora Update System 2012-12-08 18:05:54 UTC
munin-2.0.9-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.9-2.el6

Comment 7 Fedora Update System 2012-12-08 18:06:48 UTC
munin-2.0.9-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.9-2.el5

Comment 8 Fedora Update System 2012-12-08 21:06:13 UTC
Package munin-2.0.9-2.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing munin-2.0.9-2.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-13705/munin-2.0.9-2.el5
then log in and leave karma (feedback).

Comment 9 Wolfgang Denk 2012-12-10 13:18:08 UTC
(In reply to comment #8)
> Package munin-2.0.9-2.el5:
> * should fix your issue,
> * was pushed to the Fedora EPEL 5 testing repository,
> * should be available at your local mirror within two days.
> Update it with:
> # su -c 'yum update --enablerepo=epel-testing munin-2.0.9-2.el5'

Well, epel-testing is not one of the standard Fedora repositories.
Do you have some instructions how to add this?

TIA, wd.

Comment 10 Adrian Reber 2012-12-10 13:20:42 UTC
I did:

yum update --enablerepo=updates-testing munin-node

I also wondered why there has been no message how to test in on Fedora 17.

Comment 11 Fedora Update System 2012-12-18 02:31:27 UTC
munin-2.0.9-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2012-12-18 02:32:20 UTC
munin-2.0.9-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2012-12-21 19:03:34 UTC
munin-2.0.9-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.9-3.el6

Comment 14 Fedora Update System 2012-12-21 19:04:29 UTC
munin-2.0.9-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.9-3.el5

Comment 15 Fedora Update System 2013-01-09 22:14:54 UTC
munin-2.0.9-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2013-01-09 22:16:25 UTC
munin-2.0.9-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2013-01-11 23:15:54 UTC
munin-2.0.9-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Adrian Reber 2013-01-12 09:37:18 UTC
Re-opening. Now I get:

error: munin-node:9 unknown option 'su' -- ignoring line
error: munin-node:9 unexpected text

on Scientific Linux and CentOS 5.

$ rpm -q munin-node
munin-node-2.0.9-3.el5.noarch

Comment 19 Peter Meier 2013-01-12 11:48:18 UTC
I can confirm that current munin-node EPEL Packages wrongfully contain su in it and hence logrotate fails every day.

Comment 20 d. johnson 2013-01-12 19:25:53 UTC
Run this again:

yum update --enablerepo=updates-testing munin-node

Report what version you now have if you continue to have troubles.

At the moment, that would be 2.0.10-1.

Comment 21 Adrian Reber 2013-01-14 08:44:28 UTC
There is no updates-testing repository. But using epel-testing I can install 2.0.10-1.el5 and the bug seems to be fixed with 2.0.10-1.el5. Thanks. I am also closing the bug again.


Note You need to log in before you can comment on or make changes to this bug.