Bug 880566 - [ALL_LANG][SAM CLI] Unlocalized strings for system module
[ALL_LANG][SAM CLI] Unlocalized strings for system module
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-27 05:54 EST by Lijun Li
Modified: 2013-06-07 14:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:28:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-27 05:54:16 EST
Description of problem:
Unlocalized strings for system module.

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
# headpin system -h
Usage:  headpin <options> system <command>
Supported Commands:
	add_custom_info add custom infomation to a system
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
	facts          システムのハードウェア情報を表示
	info           組織内のシステムを表示
	list           組織内のシステム群を一覧表示
	register       システムを登録
	releases       システムで使用できるリリースを一覧表示
	remove_custom_info remove custom info from a system
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
	remove_deletion ハイパーバイザーの削除記録を消去
	report         システムレポート
	subscribe      システムを証明書にサブスクライブする
	subscriptions  システムのサブスクリプションを一覧表示
	unregister     システムを登録解除
	unsubscribe    証明書からシステムのサブスクリプションを解除
	update         システムを更新
	update_custom_info update custom info for a system
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
Options:
  -h, --help  show this help message and exit
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin system facts -h
Usage:  headpin <options> system facts <options>

Options:
  -h, --help            show this help message and exit
  --org=ORG             name of organization e.g.: ACME_Corporation (required)
  --environment=ENVIRONMENT
                        environment name e.g.: production
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
  --name=NAME           システム名 (必須)
  --uuid=UUID           system uuid (required)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system facts --org= --name=
Couldn't find organization 'systems'
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system facts --org=test --environment=test --name=i18nsamtest.redhat.com
----------------------------------------------------------------------------------
System Facts For System [ i18nsamtest.redhat.com ] in Environment [ test ] in Org [ test ]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
----------------------------------------------------------------------------------

# headpin -u admin -p admin system facts --org=test --uuid=??
Found ambiguous Systems [ ?? ] in Org [ test ]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin system info -h
Usage:  headpin <options> system info <options>

Options:
  -h, --help            show this help message and exit
  --org=ORG             name of organization e.g.: ACME_Corporation (required)
  --environment=ENVIRONMENT
                        environment name e.g.: production
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
  --name=NAME           システム名 (必須)
  --uuid=UUID           system uuid (required)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin system info --org=test --environment=test --name=i18nsamtest.redhat.com
----------------------------------------------------------------------------------
                環境 [ test ] に関する組織 [ test ] のシステム情報
----------------------------------------------------------------------------------

Name            : i18nsamtest.redhat.com
Ipv4 Address    : 10.66.10.14
Uuid            : a891935b-9b5e-4fc4-a7b5-3154a7330b35
Location        : なし
Registered      : 2012/11/27 15:42:49
Last updated    : 2012/11/27 15:42:49
Description:
^^^^^^^^Unlocalized
    初期の登録パラメーター
Activation Keys:
^^^^^^^^Unlocalized
    [  ]
サービスレベル         : Self-support
Custom Info:
^^^^^^^^Unlocalized
    [  ]

# headpin -u admin -p admin system info --org=test --environment=test --name=i18nsamtest.redhat.com -g
----------------------------------------------------------------------------------
                環境 [ test ] に関する組織 [ test ] のシステム情報

Name                   Ipv4 Address Uuid                                 Location Registered          Last updated        Description    Sockets RAM (MB)
                                                                ^^^^Unlocalized サービスレベル        
----------------------------------------------------------------------------------
i18nsamtest.redhat.com 10.66.10.14  a891935b-9b5e-4fc4-a7b5-3154a7330b35 なし     2012/11/27 15:42:49 2012/11/27 15:42:49 初期の登録パラメーター Self-support   


# headpin -u admin -p admin system info --org=test --uuid=??
Found ambiguous Systems [ ?? ] in Org [ test ]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin system info --org=test --uuid=a891935b-9b5e-4fc4-a7b5-3154a7330b35
----------------------------------------------------------------------------------
           System Information [ a891935b-9b5e-4fc4-a7b5-3154a7330b35 ]
           ^^^^^^^^^^^^^^^^^^^Unlocalized
----------------------------------------------------------------------------------


# headpin system list -h
Usage:  headpin <options> system list <options>

Options:
  -h, --help            show this help message and exit
  --org=ORG             name of organization e.g.: ACME_Corporation (required)
  --environment=ENVIRONMENT
                        environment name e.g.: production
  --pool=POOL_ID        pool ID to filter systems by subscriptions
                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system releases --org= --environment=
Couldn't find organization 'environments'
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin system releases --org=test --environment=test
----------------------------------------------------------------------------------
                                使用できるリリース

Value 
^^^^^^Unlocalized       
----------------------------------------------------------------------------------
5.6          
5.7          
5.8          


# headpin system register -h
Usage:  headpin <options> system register <options>

Options:
  -h, --help            show this help message and exit
  --org=ORG             name of organization e.g.: ACME_Corporation (required)
  --environment=ENVIRONMENT
                        environment name e.g.: production
  --name=NAME           システム名 (必須)
  --servicelevel=SLA    Service Level Agreement
                        ^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin system register --org=test --name=test
Organization test has more than one environment. Please specify target environment for system registration.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin system register --org=test --environment=test --name=
Validation failed: Name can't be blank
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system register --org=test --name=test --servicelevel=test --activationkey=test
Service level 'test' is not available to consumers of organization test.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system register --org=test --name=test --servicelevel=None --activationkey=test --release=test --fact=
Usage:  headpin <options> system register <options>

headpin: error: --fact option requires 2 arguments
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system subscribe --org=test --name=test --pool=
Found ambiguous Systems [ test ] in Environment [ None ] in Org [ test ], use --uuid to specify the system
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system subscribe --org=test --uuid=test  --pool=8ac28a8e3b273ec5013b3bef966d0375
Found ambiguous Systems [ test ] in Org [ test ]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin system subscriptions -h
Usage:  headpin <options> system subscriptions <options>

Options:
  -h, --help         show this help message and exit
  --org=ORG          name of organization e.g.: ACME_Corporation (required)
  --name=NAME        システム名 (必須)
  --uuid=UUID        system uuid (required)
  --available        利用可能なサブスクリプションの表示
  --match_system     show available subscriptions matching system
  --match_installed  show available subscriptions matching installed software
  --no_overlap       show available subscriptions not overlapping current
                     subscriptions
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin system subscriptions --org=test --name=test
-----------------------------------------------------------------------------------------------------------------------------
                                        システム [ test ] の現在のサブスクリプション
-----------------------------------------------------------------------------------------------------------------------------

EntitlementId  : 8ac28a8e3b273ec5013b4157e8ac0596
Serial ID      : 4763391953647761011
PoolName       : Red Hat Enterprise Linux Server, Standard (4 sockets) (Unlimited guests)
Consumed       : 1
Quantity       : 1
Sla            : Standard
ContractNumber : None
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
提供製品           : Red Hat Enterprise Linux Server


# headpin -u admin -p admin system subscriptions --org=test --uuid=??
Couldn't find system '??'
^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system subscriptions --org=test --name=i18nsamtest.redhat.com --available
----------------------------------------------------------------------------------
        システム [ i18nsamtest.redhat.com ] に使用できるサブスクリプション
----------------------------------------------------------------------------------

Id                : 8ac28a8e3b273ec5013b3bef966d0375
Name              : Red Hat Enterprise Linux Server, Standard (4 sockets) (Unlimited guests)
EndDate           : 2013-10-30T03:59:59.000+0000
Consumed          : 1
Quantity          : 96
^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
提供製品              : Red Hat Enterprise Linux Server


Id                : 8ac28a8e3b273ec5013b3bef96bd03a9
Name              : Red Hat Enterprise Linux Server, Standard (1-2 sockets) (Up to 4 guests)
EndDate           : 2013-10-30T03:59:59.000+0000
Consumed          : 1
Quantity          : 98
Stacking ID       : RH0149709
Multi-entitlement : yes
^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
提供製品              : Red Hat Enterprise Linux Server


# headpin system add_custom_info -h
Usage:  headpin <options> system add_custom_info <options>

Options:
  -h, --help            show this help message and exit
  --org=ORG             name of organization e.g.: ACME_Corporation (required)
  --environment=ENVIRONMENT
                        environment name e.g.: production
  --name=NAME           System name (required)
  --uuid=UUID           system uuid (required)
  --keyname=KEYNAME     name to identify the custom info (required)
  --value=VALUE         the custom info (required)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system add_custom_info --org=test --name=test --keyname=test --value=test
Successfully added Custom Information [ test : test ] to System [ test ]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin system update_custom_info -h
Usage:  headpin <options> system update_custom_info <options>

Options:
  -h, --help            show this help message and exit
  --org=ORG             name of organization e.g.: ACME_Corporation (required)
  --environment=ENVIRONMENT
                        environment name e.g.: production
  --name=NAME           System name (required)
  --uuid=UUID           system uuid (required)
  --keyname=KEYNAME     name to identify the custom info (required)
  --value=VALUE         replacement value
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system remove_custom_info --org=test --name=test --keyname=test
Successfully removed Custom Information from System [ test ]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin system unsubscribe -h
Usage:  headpin <options> system unsubscribe <options>

Options:
  -h, --help            show this help message and exit
  --org=ORG             name of organization e.g.: ACME_Corporation (required)
  --name=NAME           システム名 (必須)
  --uuid=UUID           system uuid (required)
  --entitlement=ENTITLEMENT
                        entitlement ID to unsubscribe from (either entitlement
                        or serial or all is required)
  --serial=SERIAL       serial ID of a certificate to unsubscribe from (either
                        entitlement or serial or all is required)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin system unregister --org=test --uuid=795aa3d3-b531-40ea-8f55-52bffa1c4bbd
Found ambiguous Systems [ 795aa3d3-b531-40ea-8f55-52bffa1c4bbd ] in Org [ test ]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized



Actual results:
Unlocalized strings for system module.

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:51 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Sam Friedmann 2012-12-14 00:55:02 EST
Confirmed for fr-FR.
Comment 3 Eunju, Kim 2012-12-14 00:59:26 EST
confirmed for ko-KR
Comment 4 Tom McKay 2012-12-18 09:12:20 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 6 Bryan Kearney 2013-06-07 14:20:04 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 7 Bryan Kearney 2013-06-07 14:28:23 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.