Bug 88057 - MultilingualItemResolver breaks if item url has . in it.
Summary: MultilingualItemResolver breaks if item url has . in it.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Justin Ross
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 87722 88926
TreeView+ depends on / blocked
 
Reported: 2003-04-04 23:03 UTC by Jon Orris
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-22 04:21:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Orris 2003-04-04 23:03:02 UTC
Description of problem:

It looks like getItemFromLiveURL is trying to resolve anything with a . in it to
a language instance & failing.

I'm concerned that the comments mention separation by : but check for .

At the least there is an undocumented, unenforced restriction on URL names for
content items.

To Reproduce:
Create a CI with dots in the name and publish it.
Try & access the live item & receive a 404

Comment 1 Justin Ross 2003-04-10 18:11:18 UTC
Fixed the low-impact way in perforce change 29694.  Actually permitting periods
in file names will require formalizing the way langauge is encoded in URLs and
changing the item resolution code to fit.

Comment 2 Richard Li 2003-04-15 22:31:30 UTC
We need to completely fix the language encoding. Targeting for Beta 2.


Note You need to log in before you can comment on or make changes to this bug.