Bug 880577 - Anaconda can't create partitions larger than 16T
Summary: Anaconda can't create partitions larger than 16T
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Samantha N. Bueno
QA Contact: Pavel Holica
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 960065 969241
TreeView+ depends on / blocked
 
Reported: 2012-11-27 11:22 UTC by Konrad Mosoń
Modified: 2015-09-28 02:06 UTC (History)
2 users (show)

Fixed In Version: anaconda-13.21.196-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 969241 (view as bug list)
Environment:
Last Closed: 2013-11-21 09:56:01 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot from iKVM with anaconda error (6.95 KB, image/png)
2012-11-28 13:53 UTC, Konrad Mosoń
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1588 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2013-11-21 00:40:22 UTC

Description Konrad Mosoń 2012-11-27 11:22:42 UTC
Description of problem:
Can't create volumes larger than 16T. Even with xfs.

Version-Release number of selected component (if applicable):
13.21.176-1.el6.centos

How reproducible:
Always.

Steps to Reproduce:
1. Create kickstart with volume larger than 16T
  
Actual results:
Error showing that maximum possible volume can be 16T


Expected results:
Volume created and formatted without any problem


Additional info:
I know that RHEL 6 e2fsprogs doesn't allow to create >16T ext4 partition, but xfs is possible. mkfs.xfs works without any problem on partitions larger than 16T, but Anaconda doesn't allow it anyway.

Comment 2 Chris Lumens 2012-11-27 21:28:23 UTC
What is the exact error message you are seeing?

Comment 3 Konrad Mosoń 2012-11-28 13:53:14 UTC
Created attachment 653555 [details]
Screenshot from iKVM with anaconda error

My line in kickstart:
part /mnt/storage --noformat --onpart=sdc1 --fstype xfs --label storage

Partition was created in previous installation. It's 65T.
Message attached.

Comment 4 Chris Lumens 2012-11-28 15:12:49 UTC
Ah, I see.  That number was based upon previous discussions about what is the maximum size we can support, but it looks like 100 TB is now the maximum supported size:

https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Storage_Administration_Guide/installconfig-fs.html

Easy to fix.

Comment 5 Konrad Mosoń 2012-11-28 16:10:55 UTC
BTW, does RHEL7 (I don't believe RHEL6.4) will support ext4 partitions larger than 16T? I know it needs newer e2fsprogs and fsck...

And those partitions limits will be larger later?

Comment 6 RHEL Product and Program Management 2013-05-06 21:14:25 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 7 Pavel Holica 2013-05-23 11:43:17 UTC
Adding qa_ack+, I'm able to reproduce this bug. No special HW is required, it's reproducible in virtual system.

Comment 12 Samantha N. Bueno 2013-07-02 14:20:52 UTC
Patch posted to anaconda-patches for review.

Comment 13 Samantha N. Bueno 2013-07-03 14:00:56 UTC
Patch pushed to rhel6-branch, commit 3fc54a69c6d3f1b9a5752dd67959b1196c37b66d.

Comment 15 Pavel Holica 2013-10-16 08:21:28 UTC
reproduced on HREL6.4 x86_64 Server
verified on RHEL6.5-20131009.0 x86_64 Server

Also verified, that anaconda creates partition on whole (65T) device when used:
part /data --size 1 --grow --asprimary --fstype xfs --ondisk=vdb

Comment 17 errata-xmlrpc 2013-11-21 09:56:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1588.html


Note You need to log in before you can comment on or make changes to this bug.