Bug 880598 - objdb: Don't read uninitialized memory in inc/dec
objdb: Don't read uninitialized memory in inc/dec
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync (Show other bugs)
6.3
All All
low Severity low
: rc
: ---
Assigned To: Jan Friesse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 07:11 EST by Jan Friesse
Modified: 2013-11-20 23:31 EST (History)
3 users (show)

See Also:
Fixed In Version: corosync-1.4.1-16.el6
Doc Type: Bug Fix
Doc Text:
Cause: Value of [u]int16 type is incremented/decremented via objdb/confdb call Consequence: API can return invalid value, because uninitialized memory is read Fix: Read only 16-bits of value instead of 32 Result: Correct value is returned and uninitialized memory is not read.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 23:31:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (3.24 KB, patch)
2012-11-27 07:11 EST, Jan Friesse
no flags Details | Diff

  None (edit)
Description Jan Friesse 2012-11-27 07:11:23 EST
Created attachment 652644 [details]
Proposed patch

Description of problem:

When object_key_increment or _decrement is called on [u]int16 value,
uninitialized value is read as result value.

Version-Release number of selected component (if applicable):
All

How reproducible:
100%

Steps to Reproduce:
1. Store [u]int16 value in confdb
2. Call object_key_increment on this key
3. valgrind will tell about access to uninitialized memory. From time to time, returned value (last parameter of object_key_increment) can be unexpected value.
  
Actual results:
Read of uninitialized value

Expected results:
No read of uninitialized value

Additional info:
"Unit test":
https://github.com/jfriesse/csts/blob/master/tests/confdb-incdec.sh
Comment 9 Jaroslav Kortus 2013-09-11 11:38:15 EDT
Verified using confdb-incdec.sh:

FAIL on corosync-1.4.1-15.el6.x86_64 (RHEL6.4) (/root/csts-apps/confdb-incdec.c:68: incdec: Assertion `res == i16inc' failed)
PASS on corosync-1.4.1-17.el6.x86_64 (RHEL6.5)
Comment 11 errata-xmlrpc 2013-11-20 23:31:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1531.html

Note You need to log in before you can comment on or make changes to this bug.