Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 880619 - keytool-maven-plugin FTBFS on rawhide (f18 is ok) - artifact org.codehaus.mojo:mojo:pom:16 is not available
Summary: keytool-maven-plugin FTBFS on rawhide (f18 is ok) - artifact org.codehaus.moj...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mojo-parent
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-27 12:47 UTC by Jaromír Cápík
Modified: 2016-02-01 01:57 UTC (History)
5 users (show)

Fixed In Version: 30-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-27 13:01:57 UTC
Type: Bug


Attachments (Terms of Use)
build.log (77.68 KB, text/x-log)
2012-11-27 12:50 UTC, Jaromír Cápík
no flags Details
build.log (4.23 KB, text/x-log)
2012-11-27 12:52 UTC, Jaromír Cápík
no flags Details

Description Jaromír Cápík 2012-11-27 12:47:19 UTC
Description of problem:
keytool-maven-plugin FTBFS on rawhide - artifact org.codehaus.mojo:mojo:pom:16 is not available ... the build log is attached

Version-Release number of selected component (if applicable):
keytool-maven-plugin-1.0-7.fc19

How reproducible:
always

Comment 1 Jaromír Cápík 2012-11-27 12:50:11 UTC
Created attachment 652658 [details]
build.log

Comment 2 Jaromír Cápík 2012-11-27 12:52:51 UTC
Created attachment 652659 [details]
build.log

wrong build.log attached ... attaching the correct one

Comment 3 Mikolaj Izdebski 2012-11-27 12:54:42 UTC
This is caused by missing org.codehaus.mojo:mojo parent POM.
I will package the POM and fix this bug.

Comment 4 Mikolaj Izdebski 2012-11-27 13:01:45 UTC
No separate package needed. Up to version 17 mojo-parent had artifactId "mojo"
In versions 18+ it's mojo-parent.

I'll add additional depmap to mojo-parent package.

Comment 5 Mikolaj Izdebski 2012-11-27 13:01:57 UTC
I believe that this bug is fixed in mojo-parent-30-2,
which is available in Fedora Rawhide.  I am closing the bug now,
thank you for reporting it.  A summary of changes is included below.

* Tue Nov 27 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 30-2
- Install additional depmap
- Resolves: rhbz#880619

Comment 6 Fedora Update System 2012-11-27 13:38:25 UTC
mojo-parent-30-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mojo-parent-30-2.fc18

Comment 7 Fedora Update System 2013-01-12 00:57:46 UTC
mojo-parent-30-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.