This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 880763 - Review Request: AudioCuesheetEditor
Review Request: AudioCuesheetEditor
Status: CLOSED DUPLICATE of bug 892335
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 13:51 EST by Sven Baus
Modified: 2013-10-19 10:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-06 14:35:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sven Baus 2012-11-27 13:51:42 EST
SPEC: https://dl.dropbox.com/u/3351272/Stuff/AudioCuesheetEditor/SPECS/AudioCuesheetEditor.spec
SOURCE: https://dl.dropbox.com/u/3351272/Stuff/AudioCuesheetEditor/SOURCES/Audio%20Cuesheet%20Editor-src.tar.gz
SRPM: coming soon
RPM: coming soon

I would like to get AudioCuesheetEditor into Fedora packages. 

I also need a sponsor ;).

TODO:
 - check the package (no rpmlint or mock has been done yet)
 - desktop file

During rpmbuild -ba it says the following error:
Ausführung(%install): /bin/sh -e /var/tmp/rpm-tmp.QHzsie
+ umask 022
+ cd /home/makerpm/rpmbuild/BUILD
+ '[' /home/makerpm/rpmbuild/BUILDROOT/AudioCuesheetEditor-0.2.0-1.fc17.x86_64 '!=' / ']'
+ rm -rf /home/makerpm/rpmbuild/BUILDROOT/AudioCuesheetEditor-0.2.0-1.fc17.x86_64
++ dirname /home/makerpm/rpmbuild/BUILDROOT/AudioCuesheetEditor-0.2.0-1.fc17.x86_64
+ mkdir -p /home/makerpm/rpmbuild/BUILDROOT
+ mkdir /home/makerpm/rpmbuild/BUILDROOT/AudioCuesheetEditor-0.2.0-1.fc17.x86_64
+ cd AudioCuesheetEditor-0.2.0
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf /home/makerpm/rpmbuild/BUILDROOT/AudioCuesheetEditor-0.2.0-1.fc17.x86_64
+ /usr/bin/make install DESTDIR=/home/makerpm/rpmbuild/BUILDROOT/AudioCuesheetEditor-0.2.0-1.fc17.x86_64
make[1]: Entering directory `/home/makerpm/rpmbuild/BUILD/AudioCuesheetEditor-0.2.0'
make[1]: Leaving directory `/home/makerpm/rpmbuild/BUILD/AudioCuesheetEditor-0.2.0'
make[1]: Entering directory `/home/makerpm/rpmbuild/BUILD/AudioCuesheetEditor-0.2.0'
make pre-install-local-hook prefix=/usr/local
make[2]: Entering directory `/home/makerpm/rpmbuild/BUILD/AudioCuesheetEditor-0.2.0'
make[2]: Leaving directory `/home/makerpm/rpmbuild/BUILD/AudioCuesheetEditor-0.2.0'
make install-satellite-assemblies prefix=/usr/local
make[2]: Entering directory `/home/makerpm/rpmbuild/BUILD/AudioCuesheetEditor-0.2.0'
mkdir -p '/home/makerpm/rpmbuild/BUILDROOT/AudioCuesheetEditor-0.2.0-1.fc17.x86_64/usr/local/lib'
cp   bin/Release /home/makerpm/rpmbuild/BUILDROOT/AudioCuesheetEditor-0.2.0-1.fc17.x86_64/usr/local/lib/audiocuesheeteditor
cp: omitting directory `bin/Release'
make[2]: *** [/home/makerpm/rpmbuild/BUILDROOT/AudioCuesheetEditor-0.2.0-1.fc17.x86_64/usr/local/lib/audiocuesheeteditor] Error 1
make[2]: Leaving directory `/home/makerpm/rpmbuild/BUILD/AudioCuesheetEditor-0.2.0'
make[1]: *** [install-local] Error 2
make[1]: Leaving directory `/home/makerpm/rpmbuild/BUILD/AudioCuesheetEditor-0.2.0'
make: *** [install-recursive] Error 1
Fehler: Fehler-Status beim Beenden von /var/tmp/rpm-tmp.QHzsie (%install)


Fehler beim Bauen des RPM:
    Fehler-Status beim Beenden von /var/tmp/rpm-tmp.QHzsie (%install)

I can build the application on my system with the standard:
./configure
make
make install

Could anybody help me? That would be fine :D!

Greets
Sven
Comment 1 Antonio Trande 2012-11-28 17:09:57 EST
Some comments:

- Source0
To help reviewers and QA scripts verify this, the packager needs to indicate where a reviewer can find the source that was used to make the rpm.
http://fedoraproject.org/wiki/Packaging:SourceURL

- BuildRequires
This must be a comma-separated list of packages required for building (compiling) the program; therefore 

BuildRequires: gtk-sharp2-devel
BuildRequires: ...

https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#BuildRequires

-
%{_libdir}/%{name}/samples/Sample_Project.ace
%{_libdir}/%{name}/%{name}.exe

These file should be erased.
http://fedoraproject.org/wiki/Packaging:Guidelines#No_inclusion_of_pre-built_binaries_or_libraries


Let me try to build.
Comment 2 Christoph Wickert 2012-11-29 07:07:01 EST
(In reply to comment #0)

> ./configure
> make
> make install

Hi Sven,

in an rpm spec file, you should use the %configure macro, see https://fedoraproject.org/wiki/Packaging:RPMMacros

You also want to speed up the build by using more than one processor, see https://fedoraproject.org/wiki/Packaging:Guidelines#Parallel_make

And last but not least you want to preserve timestamps during install, see
https://fedoraproject.org/wiki/Packaging:Guidelines#Timestamps

This results in

  %configure
  make %{?_smp_mflags}
  make install 'INSTALL=install -p'

Your package still needs a lot of work before it can be included in Fedora. Please read https://fedoraproject.org/wiki/Packaging:Guidelines and try to improve it. It's not that hard and you are doing fine. Keep up the good work!
Comment 3 Antonio Trande 2012-11-29 08:18:55 EST
(In reply to comment #2)
> (In reply to comment #0)
> 
> 
> This results in
> 
>   %configure
>   make %{?_smp_mflags}
>   make install 'INSTALL=install -p'
> 
> Your package still needs a lot of work before it can be included in Fedora.
> Please read https://fedoraproject.org/wiki/Packaging:Guidelines and try to
> improve it. It's not that hard and you are doing fine. Keep up the good work!

Hi Christoph.

As I have seen, configure built with --config=RELEASE-x86 in default (the other option is debug-x86) so, if I didn't understand fine, this rpm will be an i686 exclusively.
%configure doesn't work because it doesn't recognize --build=x86_64-unknown-linux-gnu argument (unlike of ./configure).
Is possible the use of ExclusiveArch tag ?
Or are there other ways ?         

Also for the first time I see a strange path like bin/Release/* that contains file .png and .ico .
Comment 4 Sven Baus 2012-11-29 14:03:16 EST
> %configure doesn't work because it doesn't recognize
> --build=x86_64-unknown-linux-gnu argument (unlike of ./configure).


Thats why I used ./configure. Is there a posibility to use %configure% without --build=x86_64-unknown-linux-gnu ?

> Also for the first time I see a strange path like bin/Release/* that
> contains file .png and .ico .

I'm upstream of this software. I'm developing this software for linux and windows and thought it a good idea to have the ressources under the binary path. Is this bad coding?

Also I'm not that familiar with makefiles,etc. I just used mdtools to generate the makefile automatically, and after some work, it worked :D.

Thanks for you support to get this package into fedora ;).
Comment 5 Sven Baus 2012-12-04 13:45:42 EST
Hey Antonio,

have you been able to build? 
Me for myself have found out, that on my notebook (also working with fedora 17 kde) faced the problem above mentioned:

> AudioCuesheetEditor-0.2.0-1.fc17.x86_64/usr/local/lib/audiocuesheeteditor
> cp: omitting directory `bin/Release'

Seems like there is a problem with some systems and the makefile. I'm currently working on version 0.2.1. Have you some tips that should be made?

Greetings
Sven
Comment 6 Antonio Trande 2012-12-04 14:11:01 EST
(In reply to comment #5)
> Hey Antonio,
> 
> have you been able to build? 

This is a particular case for me; for this reason I'm waiting a comment from Christoph or someone else.
Comment 7 Michael Schwendt 2012-12-09 10:43:04 EST
Setting the FE-NEEDSPONSOR flag, as I've found other tickets from you where it is still set, too.

Finding a potential sponsor is best done by being communicative about the Packaging Guidelines and the Review Guidelines. Ask questions, acknowledge the guidelines with an attempt at reviewing your own package in accordance with the ReviewGuidelines page in the Wiki. Or try to review other packages.

[...]

> Summary:        Editor for Audio Cuesheets.

No big issue, but one day all summaries will not end with a dot. I would also change the order of the words here to change the emphasis:

  Summary: Audio cuesheet editor

> Source0:        Audio Cuesheet Editor-src.tar.gz

This does not adhere to existing guidelines:
https://fedoraproject.org/wiki/Packaging:SourceURL


> Requires:       gtk-sharp2,mono-core

Are there no automatically added dependencies on what will be needed at run-time?
https://fedoraproject.org/wiki/Packaging:Guidelines#Explicit_Requires


> %description
> Anoyed of

Annoyed


> %setup -q -c %{buildroot}/AudioCuesheetEditor-%{version}

That's not what the %buildroot is for. The source is extracted somewhere in the $RPM_BUILD_DIR which is neither $RPM_BUILD_ROOT nor %buildroot. Simply use a relative path here,

  %setup -q -c AudioCuesheetEditor-%{version}

and examine the rpmbuild output to understand how and when this directory is used and think twice whether you might modify your source release tarball so that creating this directory will not be necessary anymore. For example, if the top dir of the source is %{name}-%{version} already, you don't need this -c option as you can use %setup's default, which is -n %{name}-%{version}.


> ./configure

Add a comment on why %configure is not used and whether any options are not needed. E.g. whether or why --libdir=%{_libdir} is not needed. See output of "rpm --eval %configure" for comparison. Getting the configure call right can become especially important when any paths are built into the software and must match the location of the files as installed by %make_install (or similar invocations).


> %install
> rm -rf $RPM_BUILD_ROOT

https://fedoraproject.org/wiki/Packaging:Guidelines#BuildRoot_tag


> %{_libdir}/%{name}/resources/Texts.xml
> %{_libdir}/%{name}/resources/icons/application-x-cue-16.ico
> ...

https://fedoraproject.org/wiki/Packaging:UnownedDirectories


> %{_libdir}/%{name}/resources/icons/application-x-cue-16.png
> %{_libdir}/%{name}/resources/icons/application-x-cue-22.ico

Maybe you would like to use the '*' wildcard here to reduce the number if entries? You can also include entire directories with a single line.
Comment 8 Sven Baus 2012-12-09 13:39:23 EST
Thanks for your comments Michael, but I'm currently waiting for Antonio to report, that he has been able to build the package. Me for myself had the problem with the source package on my notebook, but on my desktop I've been able to build.

Since I'm upstream, I would like to know, where the problem is. Maybe it's a problem inside the makefile or configure script of source package. If you have knowledge of makefiles, etc. I really would like to invite you to check the source package ;).
Comment 9 Michael Schwendt 2012-12-12 16:09:45 EST
Sven, at which step of the following process are you?

  https://fedoraproject.org/wiki/Join_the_package_collection_maintainers

Have you tried to submit a scratch build in the Fedora Build System yet?

[...]

A local build in Plague here fails:

+ ./configure
Looking for required packages
Checking for package 'glade-sharp-2.0'.. ERROR: Package named 'glade-sharp-2.0' >= 2.12.11 not found.
Try adjusting your PKG_CONFIG_PATH environment variable.
Comment 10 Sven Baus 2012-12-17 06:05:53 EST
(In reply to comment #9)
> Sven, at which step of the following process are you?
> 
>   https://fedoraproject.org/wiki/Join_the_package_collection_maintainers
> 
> Have you tried to submit a scratch build in the Fedora Build System yet?

No, I have not. Currently I'm trying to get the package build on my local system for testing purposes. Afterwards I would go on.

I'm now checking why build from source on some system fails with the errors mentioned above. Maybe version 0.2.1 is a able to build, then I would just go on with version 0.2.1 (which is almost done) ;).
Comment 11 Michael Schwendt 2012-12-17 06:42:28 EST
It fails because you BuildRequires are incomplete. At least "gtk-sharp2-devel" is missing. In turn, the pkg-config based check in the configure script fails:

# repoquery --whatprovides 'pkgconfig(glade-sharp-2.0)'
gtk-sharp2-devel-0:2.12.11-6.fc18.i686
gtk-sharp2-devel-0:2.12.11-6.fc18.x86_64
Or also:
# repoquery --whatprovides \*glade-sharp-2.0.pc
gtk-sharp2-devel-0:2.12.11-6.fc18.i686
gtk-sharp2-devel-0:2.12.11-6.fc18.x86_64
Comment 12 Sven Baus 2012-12-31 06:54:05 EST
Hello everybody,

I have finished work for version 0.2.1, so the next review request will come in some days. I have also found out, that it is better to use xbuild building the source, since the makefile just sometimes works and sometimes not (I don't understand why). 

So thanks for your help, we will meet in the next year ;).

Greetings 
Sven
Comment 13 Sven Baus 2013-01-06 14:35:27 EST

*** This bug has been marked as a duplicate of bug 892335 ***

Note You need to log in before you can comment on or make changes to this bug.