Bug 880805 - virt-df with two -a options displays incorrect disk image name
Summary: virt-df with two -a options displays incorrect disk image name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 880801
Blocks: 886216
TreeView+ depends on / blocked
 
Reported: 2012-11-27 20:12 UTC by Richard W.M. Jones
Modified: 2013-02-21 08:38 UTC (History)
7 users (show)

Fixed In Version: libguestfs-1.16.32-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 880801
Environment:
Last Closed: 2013-02-21 08:38:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0324 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2013-02-20 20:54:42 UTC

Description Richard W.M. Jones 2012-11-27 20:12:52 UTC
+++ This bug was initially created as a clone of Bug #880801 +++

Description of problem:

(Reported by muued on IRC)

$ sudo virt-df -a /dev/vg_pin/Debian5x64 -a /dev/vg_pin/WinXP
Filesystem                           1K-blocks       Used  Available  Use%
WinXP:/dev/sda1                         329679      67325     244787   21%
WinXP:/dev/sdb1                        6281380    2812564    3468816   45%
WinXP:/dev/debian5x64.home.annexia.org/home
                                       3555936     365544    3009760   11%
WinXP:/dev/debian5x64.home.annexia.org/root
                                        329233     309786       2449   95%
WinXP:/dev/debian5x64.home.annexia.org/tmp
                                        309401      10292     283135    4%
WinXP:/dev/debian5x64.home.annexia.org/usr
                                       3539776    2089124    1270840   60%
WinXP:/dev/debian5x64.home.annexia.org/var
                                       2774352    2088408     548332   76%

Version-Release number of selected component (if applicable):

libguestfs 1.18.10
libguestfs 1.19.64

How reproducible:

100%

Steps to Reproduce:
1. Run virt-df with two -a options.

Comment 1 Richard W.M. Jones 2012-11-27 20:13:59 UTC
Also affects RHEL 6:

$ sudo virt-df -a /dev/vg_guests/builder-rhel6 -a /dev/vg_guests/builder-rhel7 
Filesystem                           1K-blocks       Used  Available  Use%
builder-rhel7:/dev/sda1                 495844      75873     394371   16%
builder-rhel7:/dev/sdb1                 495844      45885     424359   10%
builder-rhel7:/dev/rhel/root          49064776    3744168   42828192    8%
builder-rhel7:/dev/vg_builderrhel6/lv_root
                                      38745920   15172932   21604860   40%

Comment 2 Wei Shi 2012-11-28 02:07:33 UTC
Reproduced:

# virt-df -a RHEL-Server-5.9-32-pv.raw -a opensuse.img
Filesystem                           1K-blocks       Used  Available  Use%
opensuse.img:/dev/sda1                  101086      27804      68063   28%
opensuse.img:/dev/sdb1                   69410      25773      40053   38%
opensuse.img:/dev/VolGroup00/LogVol00
                                       4919856    3773492     892412   77%
opensuse.img:/dev/system/root          6116032    3008600    2796752   50%

# virt-df -a RHEL-Server-5.9-32-pv.raw
Filesystem                           1K-blocks       Used  Available  Use%
RHEL-Server-5.9-32-pv.raw:/dev/sda1     101086      27804      68063   28%
RHEL-Server-5.9-32-pv.raw:/dev/VolGroup00/LogVol00
                                       4919856    3773492     892412   77%

# virt-df -a opensuse.img
Filesystem                           1K-blocks       Used  Available  Use%
opensuse.img:/dev/sda1                   69410      25773      40053   38%
opensuse.img:/dev/system/root          6116032    3008600    2796752   50%

Comment 3 Richard W.M. Jones 2012-11-29 11:48:49 UTC
Upstream fix here:
https://github.com/libguestfs/libguestfs/commit/9e7daf2ee8f0a619440ca1c55dfe5ddcf61b4460

Comment 4 Richard W.M. Jones 2012-11-30 17:12:00 UTC
Building here:
https://brewweb.devel.redhat.com/taskinfo?taskID=5149926

Comment 6 Wei Shi 2012-12-03 09:37:48 UTC
I verified the fixed package, the result is just as https://bugzilla.redhat.com/show_bug.cgi?id=880801#c1 and the updated virt-df manual.

# virt-df -a RHEL-Server-5.9-32-pv.raw -a opensuse.img
Filesystem                           1K-blocks       Used  Available  Use%
RHEL-Server-5.9-32-pv.raw+:/dev/sda1    101086      27804      68063   28%
RHEL-Server-5.9-32-pv.raw+:/dev/sdb1     69410      25773      40053   38%
RHEL-Server-5.9-32-pv.raw+:/dev/VolGroup00/LogVol00
                                       4919856    3773492     892412   77%
RHEL-Server-5.9-32-pv.raw+:/dev/system/root
                                       6116032    3008600    2796752   50%
# virt-df -a RHEL-Server-5.9-32-pv.raw
Filesystem                           1K-blocks       Used  Available  Use%
RHEL-Server-5.9-32-pv.raw:/dev/sda1     101086      27804      68063   28%
RHEL-Server-5.9-32-pv.raw:/dev/VolGroup00/LogVol00
                                       4919856    3773492     892412   77%
# virt-df -a opensuse.img
Filesystem                           1K-blocks       Used  Available  Use%
opensuse.img:/dev/sda1                   69410      25773      40053   38%
opensuse.img:/dev/system/root          6116032    3008600    2796752   50%


I just doubt how could the user distinguish the first and second disk images, the "+" seems just indicate the user has given more than one disk images. For example: the filesystem "/dev/system/root" can't be identified to own by which disk image.

If this is acceptable, i'll mark the status to verified.

Comment 7 Richard W.M. Jones 2012-12-03 10:00:48 UTC
The problem is that the user is using the program wrong, and
needs to read the manual.  If you take a look at the new
virt-df man page you should see that I have highlighted the
issues in (more) bold.  I have also added an example showing
the '+' character appearing and what that means.

In any case, the '+' character is what is supposed to have
changed, so the fix is working correctly.

Comment 8 Wei Shi 2012-12-03 10:30:40 UTC
(In reply to comment #7)
> The problem is that the user is using the program wrong, and
> needs to read the manual.  If you take a look at the new
> virt-df man page you should see that I have highlighted the
> issues in (more) bold.  I have also added an example showing
> the '+' character appearing and what that means.
> 
> In any case, the '+' character is what is supposed to have
> changed, so the fix is working correctly.

Yes, i saw your update for virt-df manual, so update the status to VERIFIED base on the result c6.

Comment 10 errata-xmlrpc 2013-02-21 08:38:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0324.html


Note You need to log in before you can comment on or make changes to this bug.