Bug 880833 - [RFE] libelf provides gelf_msize, elfutils-libelf can provide this as well
Summary: [RFE] libelf provides gelf_msize, elfutils-libelf can provide this as well
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: elfutils
Version: 6.3
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Petr Machata
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-27 20:54 UTC by jcpunk
Modified: 2015-05-05 01:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-03 18:43:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to add gelf_msize (code from libelf-0.8.13) (496 bytes, patch)
2012-11-27 20:54 UTC, jcpunk
no flags Details | Diff

Description jcpunk 2012-11-27 20:54:10 UTC
Created attachment 653114 [details]
patch to add gelf_msize (code from libelf-0.8.13)

Description of problem: I've an application that wishes to utilize these symbols.  However, I can't compile it due to the missing symbol.


Version-Release number of selected component (if applicable):elfutils-0.152-1.el6


How reproducible: 100%


Steps to Reproduce:
1. attempt to compile something that works fine with libelf-0.8.13
2. fail
3.
  
Actual results:
unable to compile

Expected results:
able to use elfutils-libelf instead of libelf since one is supported.

Additional info:

An opensource program using this symbol
http://eggy.yolky.org/pylibelf/static/docs/index.html

Comment 2 Petr Machata 2012-11-30 15:27:44 UTC
Is there any documentation on what this function should do?  And in particular, why gelf_fsize wouldn't do?  From what's in libelf it looks like there's a separate type hierarchy defined over character arrays instead of the actual types, but the resulting layout is the same.  gelf_fsize should therefore give the same results as gelf_msize.  Since the latter is utterly non-standard, undocumented and seemingly redundant, I'm disinclined to implement and support this.

Comment 3 jcpunk 2012-12-03 17:10:12 UTC
gelf_fsize works for me, didn't realize they were the same in the end.


Note You need to log in before you can comment on or make changes to this bug.