Bug 880851 - Mozplugger fails to embed evince
Mozplugger fails to embed evince
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mozplugger (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 17:14 EST by Yajo
Modified: 2013-08-01 14:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 14:09:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Configuration file (12.64 KB, text/plain)
2012-11-28 15:27 EST, Yajo
no flags Details
new config file (12.65 KB, application/octet-stream)
2012-11-29 05:51 EST, Ngo Than
no flags Details

  None (edit)
Description Yajo 2012-11-27 17:14:29 EST
Description of problem:
Mozplugger opens PDFs in a separate evince window.

Version-Release number of selected component (if applicable):
$ rpm -q mozplugger firefox evince
mozplugger-1.14.3-2.fc17.x86_64
firefox-17.0-1.fc17.x86_64
evince-3.4.0-2.fc17.x86_64

Steps to Reproduce:
1. Install the above packages
2. Ensure mozplugger is active in Firefox
3. Open a PDF file in Firefox
  
Actual results:
A new evince window is opened. Firefox loses the handle of keyboard shortcuts.

Expected results:
Evince opened inside Firefox.
Comment 1 Ngo Than 2012-11-28 09:18:56 EST
could you please attach the /etc/mozpluggerrc ?
thanks
Comment 2 Yajo 2012-11-28 15:27:55 EST
Created attachment 653738 [details]
Configuration file

It's unmodified, installed from the repos.
Comment 3 Ngo Than 2012-11-29 05:51:47 EST
Created attachment 654155 [details]
new config file

i upload the new config file which should fix the above issue. Could you please copy it to /etc/ and try again?

thanks
Comment 4 Yajo 2012-11-30 09:29:44 EST
Thanks, it works now. However, the embeded Evince catches Firefox's keyboard shortcuts. Is this normal?
Comment 5 Ngo Than 2012-12-05 05:23:17 EST
(In reply to comment #4)
> Thanks, it works now. However, the embeded Evince catches Firefox's keyboard
> shortcuts. Is this normal?

yes, it's expected behavour
Comment 6 Yajo 2012-12-08 17:55:28 EST
I noticed that the embeded Evince uses the greyed-out color theme in Gnome 3 (the theme applied to the windows that you are not using). Is it normal?

Also it fails to embed LibreOffice, do I open a new bug for this?

Thanks a lot.
Comment 7 Fedora End Of Life 2013-07-04 02:34:24 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2013-08-01 14:09:10 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.