Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 880854 - Community site is using incorrect favicon
Summary: Community site is using incorrect favicon
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Steve Goodwin
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-27 22:40 UTC by Emily Dirsh
Modified: 2015-11-02 00:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-24 03:22:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of two openshift pages using different favicons (100.91 KB, image/png)
2012-11-27 22:40 UTC, Emily Dirsh
no flags Details
different favicons on Safari (639.95 KB, image/jpeg)
2012-12-12 08:15 UTC, Yujie Zhang
no flags Details
favicons on Chrome24,IE9 and IE10 (252.54 KB, image/png)
2013-01-24 03:21 UTC, Yujie Zhang
no flags Details
new screenshot (31.48 KB, image/png)
2013-03-08 08:20 UTC, Yujie Zhang
no flags Details
different on chrome 26 (7.95 KB, image/jpeg)
2013-04-07 03:37 UTC, weiwei jiang
no flags Details
different on chrome 26 (7.95 KB, image/jpeg)
2013-04-07 03:37 UTC, weiwei jiang
no flags Details
Chrome 26 on Mac shows same favicon (61.29 KB, image/png)
2013-04-15 15:08 UTC, Steve Goodwin
no flags Details
chrome26 on win7 with the code of the part of "head" (194.84 KB, image/png)
2013-04-18 02:26 UTC, weiwei jiang
no flags Details
google-chrome 26 for devenv_3194 (224.32 KB, image/png)
2013-05-08 09:39 UTC, weiwei jiang
no flags Details
devenv_3810_IE10 (73.42 KB, image/png)
2013-09-23 02:54 UTC, Tian Feng
no flags Details
devenv_3810_IE9 (140.18 KB, image/png)
2013-09-23 03:00 UTC, Tian Feng
no flags Details

Description Emily Dirsh 2012-11-27 22:40:45 UTC
Created attachment 653168 [details]
Screenshot of two openshift pages using different favicons

Description of problem:
The favicon for the community site is incorrect.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open any page in the community site
2. View favicon
  
Actual results:
Favicon is wrong

Expected results:
Favicon is normal OpenShift logo

Additional info:
The console and home page have the correct favicon, but the drupal site is using an old, incorrect favicon of dubious origin.

Comment 1 Clayton Coleman 2012-12-06 02:47:55 UTC
Looks correct to me?

Comment 2 Yujie Zhang 2012-12-06 10:22:14 UTC
(In reply to comment #1)
hi Clayton, I think Emily means this Bug 879510, which is already closed as not a bug.

Comment 3 Yujie Zhang 2012-12-11 09:46:44 UTC
(In reply to comment #1)
Hi Clayton, did you fix this bug? Can you give me the pull request? Thanks!

Comment 4 Yujie Zhang 2012-12-11 10:05:52 UTC
Tested on devenv_2582, it is still not fixed, so assign it back.

Comment 5 Yujie Zhang 2012-12-12 08:14:06 UTC
(In reply to comment #1)
This issue also exists on safari, details see my screenshot on Mac.

Comment 6 Yujie Zhang 2012-12-12 08:15:06 UTC
Created attachment 662106 [details]
different favicons on Safari

Comment 7 Clayton Coleman 2013-01-23 07:43:34 UTC
Fixed in https://github.com/openshift/li/pull/780

Comment 8 openshift-github-bot 2013-01-23 11:52:23 UTC
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/e820417da9a6b9c6443092c86fb66a630102d58d
Bug 880854 - Fix community favicon in some browsers

Comment 9 Yujie Zhang 2013-01-24 03:13:13 UTC
(In reply to comment #7)
Tested on devenv_2716, community is using the same favicon on Safari5,
on Chrome24, the favicon of community is different with console, the circle is bolder, it's not easy to figure, but that should be Emily's point.
on IE9 and IE10, the favicon can not be displayed correctly, details you can see in the attachment.So, could you please check this again? Thanks!

Comment 10 Yujie Zhang 2013-01-24 03:21:18 UTC
Created attachment 686423 [details]
favicons on Chrome24,IE9 and IE10

Comment 11 Clayton Coleman 2013-03-05 19:54:37 UTC
I've added a note to the operations ticket for both openshift.redhat.com and openshift.com to make sure this icon is available.

Comment 12 Clayton Coleman 2013-03-06 15:57:28 UTC
Verify this on INT once https://engineering.redhat.com/trac/Libra/wiki/Releases/2.0.24#Comment22clayton is completed

Comment 13 Yujie Zhang 2013-03-07 11:46:53 UTC
Tested on INT(devenv_2905), the issue still exists, will test it again when the above note is completed.

Comment 14 Yujie Zhang 2013-03-08 08:17:23 UTC
Tested on INT(devenv_2910), the issue still exists, could you please check this again? Details see in attachment.

Comment 15 Yujie Zhang 2013-03-08 08:20:09 UTC
Created attachment 706943 [details]
new screenshot

Comment 16 Clayton Coleman 2013-03-28 22:46:40 UTC
Ops fixed another issue.

Comment 17 Yujie Zhang 2013-03-29 11:21:21 UTC
Tried on devenv-stage_331, this issue still exists, could you please specify the pull request? or where should I test this issue? Thanks!

Comment 19 weiwei jiang 2013-04-07 03:37:01 UTC
Created attachment 732262 [details]
different on chrome 26

tried on  devenv_304,still appear

Comment 20 weiwei jiang 2013-04-07 03:37:59 UTC
Created attachment 732263 [details]
different on chrome 26

tried on  devenv_304 , still appear

Comment 21 joycezhang 2013-04-07 05:36:00 UTC
Assign this bug back as it's still reproduced on devenv_3049 as mentioned above. Thanks.

Comment 22 Steve Goodwin 2013-04-15 15:07:06 UTC
Are you seeing this on Chrome on the Windows platform?

I'm seeing the same favicon on Chrome 26 on the OS X. see screenshot

Comment 23 Steve Goodwin 2013-04-15 15:08:08 UTC
Created attachment 735957 [details]
Chrome 26 on Mac shows same favicon

Comment 24 weiwei jiang 2013-04-18 02:26:16 UTC
Created attachment 737109 [details]
chrome26 on win7 with the code of the part of "head"

Comment 25 weiwei jiang 2013-04-18 02:45:04 UTC
the head code of "community" have  two rel="shortcut icon", and /app/login page have only one. I guess maybe browser use the first "shortcut icon" on community page.

Comment 26 Clayton Coleman 2013-05-07 22:25:22 UTC
We pushed a small fix as part of changes last sprint, is this still occurring?  I can't reproduce against production (the icon doesn't show up at first, but on subsequent loads it does show up).

Comment 27 weiwei jiang 2013-05-08 09:39:55 UTC
Created attachment 745149 [details]
google-chrome 26 for devenv_3194

Comment 28 Clayton Coleman 2013-05-08 13:44:13 UTC
That looks correct to me?

Comment 29 weiwei jiang 2013-05-09 01:34:16 UTC
Please notice the head part code of every page, some page(community releated) have two rel="shortcut icon", and one pointed to "/sites/all/themes/openshift-theme/favicon.ico", another pointed to "/app/assets/favicon32.png".
"favicon.ico" will cover "favicon32.png" when browser rendering the page.

You can zoom in the picture and will notice that "favicon.ico" is a little bigger than "favicon32.png".

Comment 30 Steve Goodwin 2013-07-02 14:31:52 UTC
Fix committed and merged

Comment 31 weiwei jiang 2013-07-03 03:40:55 UTC
I tried on devenv_3439 and found that chrome/firefox is ok now but IE10/IE9 not display, and on stg community page display and console page not display for IE10.

Comment 32 Clayton Coleman 2013-07-09 19:52:00 UTC
STG is not updated with Steve's changes yet.  Steve, can you look at IE9/10?

Comment 33 Steve Goodwin 2013-07-11 14:55:02 UTC
I'm waiting on a request from servicedesk for access to a VM to test IE

IE9 should show
https://github.com/openshift/li/blob/master/site/app/assets/images/favicon.ico

IE10 should show /favicon.ico in our root directory. which one?
https://github.com/openshift/li/blob/master/site/public/images/favicon.ico
https://github.com/openshift/li/blob/master/site/public/favicon.ico

Comment 34 Steve Goodwin 2013-07-16 13:55:42 UTC
Addition fix committed 
devenv_3488


...me crossing fingers

Comment 35 weiwei jiang 2013-07-17 05:02:23 UTC
I tried on devenv_3514& STG(dev_stage_406), and found that STG work well for IE9/IE10, but devenv_3514 still can not display favicon.

Comment 36 Tian Feng 2013-09-22 03:22:06 UTC
Test on STG and devenv_3810, I find the favicon.ico on web console and community have the same md5sum. And they display well on firefox & chrome.
But on devenv_3810, the favicon.ico are disappear on IE9 & IE10.

Comment 37 Tian Feng 2013-09-23 02:54:19 UTC
Created attachment 801475 [details]
devenv_3810_IE10

Comment 38 Tian Feng 2013-09-23 03:00:15 UTC
Created attachment 801476 [details]
devenv_3810_IE9

Comment 39 Steve Goodwin 2013-11-14 20:25:40 UTC
I don't know why a devenv would not show the favicon in IE.

If QE can confirm it shows correctly in IE 9 & 10 on INT, STG, and production environments, I vote to mark this bug as fixed, unless there are any objections.

Comment 40 Tian Feng 2013-11-15 02:16:12 UTC
I agree with Steve. Things always perform weird on IE. Since favicon performs well on INT, STG and PROD, no need to dig out the reason why favicon is not correct on devenv. So verify this bug, thanks all!


Note You need to log in before you can comment on or make changes to this bug.