Bug 880901 - [RHEV-RHS] "openssl" fs sanity test failed on fuse mount
[RHEV-RHS] "openssl" fs sanity test failed on fuse mount
Status: CLOSED DUPLICATE of bug 856467
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Raghavendra Bhat
spandura
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 00:23 EST by spandura
Modified: 2012-12-11 01:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 01:45:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description spandura 2012-11-28 00:23:55 EST
Description of problem:
=====================
Running "openssl" sanity test on fuse mount for a replicate, distribute-replicate volume failed. 


Version-Release number of selected component (if applicable):
==============================================================
[11/28/12 - 09:11:22 root@rhs-gp-srv12 system_light]# glusterfs --version
glusterfs 3.3.0rhsvirt1 built on Nov  7 2012 10:11:13

[11/28/12 - 09:11:31 root@rhs-gp-srv12 system_light]# rpm -qa | grep gluster
glusterfs-fuse-3.3.0rhsvirt1-8.el6.x86_64
glusterfs-3.3.0rhsvirt1-8.el6.x86_64

How reproducible:
=================
Often

Steps to Reproduce:
======================
1. Create a replicate volume (1x2) with 2 servers and 1 brick on each server. This is the storage for the VM's.

2. Set the volume option "group" to "virt"

3. Set storage.owner-uid , storage.owner-gid to 36.

4. start the volume. 

5. create a host from RHEVM

6. create a storage domain from RHEVM for the above created volume. 

7. On the host mount point to the volume, run "openssl" sanity test : 
    a. create nfs mount to qa tools ( mount -t nfs 10.70.34.114:/opt /opt )
    b. cd /opt/qa/tools/system_light
    c. ./run.sh -w <mount_point> -l <log_file> -t "openssl" 
  
Actual results:
===========================TESTS RUNNING===========================
Changing to the specified mountpoint
/rhev/data-center/mnt/rhs-client1.lab.eng.blr.redhat.com:_replicate/run21655
executing openssl
untarring the openssl tarball
start:09:22:53

real    70m0.006s
user    0m0.363s
sys     0m1.260s
executing ./config:10:32:53

real    0m3.854s
user    0m1.375s
sys     0m0.498s
executing make:10:32:56

real    0m2.817s
user    0m0.755s
sys     0m0.224s
make failed:10:32:59
openssl failed
0
Total 0 tests were successful
Switching over to the previous working directory
Removing /rhev/data-center/mnt/rhs-client1.lab.eng.blr.redhat.com:_replicate//run21655/
rmdir: failed to remove `/rhev/data-center/mnt/rhs-client1.lab.eng.blr.redhat.com:_replicate//run21655/': Directory not empty
rmdir failed:Directory not empty

Output from <log_file> 
------------------------
gcc -I. -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -m64 -DL_ENDIAN -DTERMIO -O3 -Wall -DMD32_REG_T=int -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DAES_ASM -DWHIRLPOOL_ASM -c  -o x86_64cpuid.o x86_64cpuid.s
ar  r ../libcrypto.a cryptlib.o mem.o mem_dbg.o cversion.o ex_data.o cpt_err.o ebcdic.o uid.o o_time.o o_str.o o_dir.o x86_64cpuid.o
ar: creating ../libcrypto.a
ar: ../libcrypto.a: File format is ambiguous
ar: Matching formats: elf32-i386 a.out-i386-linux pei-i386 pei-x86-64 elf64-l1om elf64-little elf64-big elf32-little elf32-big
make[1]: *** [../libcrypto.a] Error 1
make[1]: Leaving directory `/rhev/data-center/mnt/rhs-client1.lab.eng.blr.redhat.com:_replicate/run21655/openssl-1.0.0d/crypto'
make: *** [build_crypto] Error 1

Expected results:
==================
Running "openssl" sanity test should pass. 

Additional info:
===============
Volume Name: replicate
Type: Replicate
Volume ID: d93217ad-aa06-49df-80bf-b0539e5eba72
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: rhs-client1:/disk1
Brick2: rhs-client16:/disk1
Options Reconfigured:
storage.owner-gid: 36
storage.owner-uid: 36
cluster.eager-lock: enable
storage.linux-aio: enable
performance.stat-prefetch: off
performance.io-cache: off
performance.read-ahead: off
performance.quick-read: off


Note: The same test passes when executed on regular file system
===============================================================

[11/28/12 - 10:42:07 root@rhs-gp-srv12 system_light]# mkdir /openssl_testdir

[11/28/12 - 10:43:01 root@rhs-gp-srv12 system_light]# ./run.sh -w /openssl_testdir/ -l /fs_sanity_logs/fs_sanity_replicate_3.3.0rhsvirt1-8.el6.x86_64_`hostname`_`date '+%Y'`"_"`date '+%m'`"_"`date '+%d'`"_"`date '+%H'`"_"`date '+%M'`"_"`date '+%S'`_openssl.log -t "openssl"
/opt/qa/tools/system_light
Tests available:
arequal
bonnie
compile_kernel
dbench
dd
ffsb
fileop
fs_mark
fsx
glusterfs_build
iozone
locks
ltp
multiple_files
openssl
posix_compliance
postmark
read_large
rpc
syscallbench
tiobench
===========================TESTS RUNNING===========================
Changing to the specified mountpoint
/openssl_testdir/run26220
executing openssl
untarring the openssl tarball
start:10:43:27

real    0m0.233s
user    0m0.197s
sys     0m0.180s
executing ./config:10:43:28

real    0m1.913s
user    0m1.355s
sys     0m0.418s
executing make:10:43:30

real    1m36.433s
user    1m21.674s
sys     0m12.844s
executing make test:10:45:06

real    0m24.232s
user    0m17.244s
sys     0m4.210s
removed openssl directories and files
1
Total 1 tests were successful
Switching over to the previous working directory
Removing /openssl_testdir//run26220/
Comment 3 Rachana Patel 2012-12-03 01:25:07 EST
It is also failing for DHT - FUSE mount
Comment 4 Vijay Bellur 2012-12-11 01:45:26 EST

*** This bug has been marked as a duplicate of bug 856467 ***

Note You need to log in before you can comment on or make changes to this bug.