This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 880915 - [ALL LANG][SAM Web GUI] Unexpected message : Resources::Candlepin::CandlepinResource: 410 Gone {"displayMessage":"Consumer xxxx has been deleted"...} occurred in Systems application tab.
[ALL LANG][SAM Web GUI] Unexpected message : Resources::Candlepin::CandlepinR...
Status: CLOSED WORKSFORME
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
high Severity urgent
: rc
: ---
Assigned To: Tom McKay
SAM QE List
: i18n
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-28 01:36 EST by Lijun Li
Modified: 2012-12-18 08:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 08:01:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Unexpected message :'Resources::Candlepin::CandlepinResource: 410 Gone' (80.86 KB, image/png)
2012-11-28 01:40 EST, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-11-28 01:36:28 EST
Description of problem:
Unexpected message : Resources::Candlepin::CandlepinResource: 410 Gone {"displayMessage":"Consumer xxxx has been deleted"...}. occurred in Systems application tab.

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Log in SAM Web GUI and import the manifest.
2. Register the system to SAM via RHSM.
3. Delete the system (/delete consumer)
4. Click Systems application tab.
  
Actual results:
Unexpected message :
Resources::Candlepin::CandlepinResource: 410 Gone {"displayMessage":"Consumer 59cc3483-15b4-456c-905c-8eccdfb6bfdd has been deleted","deletedId":"59cc3483-15b4-456c-905c-8eccdfb6bfdd"} (GET /candlepin/consumers/59cc3483-15b4-456c-905c-8eccdfb6bfdd/compliance) (RestClient::Gone)
{"displayMessage":"Consumer 59cc3483-15b4-456c-905c-8eccdfb6bfdd has been deleted","deletedId":"59cc3483-15b4-456c-905c-8eccdfb6bfdd"} 


Expected results:
Should have no such errors always poped up.

Additional info:
Comment 1 Lijun Li 2012-11-28 01:40:34 EST
Created attachment 653312 [details]
Unexpected message :'Resources::Candlepin::CandlepinResource: 410 Gone'
Comment 2 Tom McKay 2012-11-28 08:24:19 EST
What command was specifically run at this step?
> 3. Delete the system (/delete consumer)
Comment 3 Lijun Li 2012-11-28 21:13:42 EST
(In reply to comment #2)
> What command was specifically run at this step?
> > 3. Delete the system (/delete consumer)

Remove the system via Web GUI or Unregister the system via CLI:
headpin -u admin -p admin system unregister --org=test --name=i18nsamtest.redhat.com

OR after deleting the manifest and reproduce the above steps.

Thanks,
Robert
Comment 4 Tom McKay 2012-12-04 15:35:13 EST
Unable to reproduce so far
Comment 5 Satyabrata Maitra 2012-12-05 05:27:22 EST
Unable to reproduce. Please let the reporter make some further input.
Comment 6 Lijun Li 2012-12-10 22:54:02 EST
Will verify it on the latest build.
Comment 7 Lijun Li 2012-12-10 23:57:22 EST
This issue is not easy to reproduce and I'd like to check it on the latest build again and update the steps if it can be reproduced.
Comment 8 Tom McKay 2012-12-18 08:01:03 EST
Please re-open if/when reproducible

Note You need to log in before you can comment on or make changes to this bug.