Bug 880938 - Overwrite existed HostVG function didn't work during TUI install process
Overwrite existed HostVG function didn't work during TUI install process
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 03:38 EST by haiyang,dong
Modified: 2013-02-28 11:46 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-11.el6
Doc Type: Bug Fix
Doc Text:
Previously, when an existing host volume group was detected on an installation device, users were prompted to overwrite the host volume group. Now, if a host volume group is detected on an installation device, users are prompted to reboot the hypervisor and select the reinstall option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:46:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
attached the ovirt.log (6.00 KB, text/x-log)
2012-11-28 03:42 EST, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2012-11-28 03:38:53 EST
Description of problem: 
Overwrite exited HostVG function didn't work during TUI install process

Version-Release number of selected component (if applicable): 
rhev-hypervisor6-6.4-20121126.0.el6

How reproducible: 
100%
 
Steps to Reproduce:
1. Boot from PXE and install RHEV-H.
2. Select USB device to use for booting RHEV-H.
3. Select USB device to use for installation of RHEV-H.
4. Finish the installation process. 
5. Then unplug the usb media from local host
6. Boot from PXE and install RHEV-H via TUI.
7. Enter "Select the disk to use for booting RHEV Hyervisor" page 
8. Plug that USB media(has been installed rhev-h) into local host.
9. Refresh the page and select USB device to use for booting RHEV-H.
10.Then enter "Please select the disk(s) to use for installation of RHEV Hyervisor" page.
11.Select USB media(has been installed rhev-h) to use for installation of RHEV-H.
12. Prompt that "Exiting HostVG Detected on /dev/sdb4, Overwrite?",then click "OK" button.

Actual result:
After step12, "Exiting HostVG Detected on /dev/sdb4, Overwrite?" function didn't work during install process

Expect result:
After step12, Overwrite exited HostVG Detected on /dev/sdb4 should success.
Comment 2 haiyang,dong 2012-11-28 03:42:51 EST
Created attachment 653348 [details]
attached the ovirt.log
Comment 3 haiyang,dong 2012-11-28 21:11:27 EST
No this issue on build rhev-hypervisor6-6.3-20121121.0.el6_3, so it's a regression bug from 6.3 to 6.4
Comment 10 haiyang,dong 2012-12-18 01:22:42 EST
Test version:
rhev-hypervisor6-6.4-20121212.1.el6 
ovirt-node-2.5.0-11.el6

Tested as follows:
Steps to Reproduce:
1. Boot from PXE and install RHEV-H.
2. Select USB device to use for booting RHEV-H.
3. Select USB device to use for installation of RHEV-H.
4. Finish the installation process. 
5. Then unplug the usb media from local host
6. Boot from PXE and install RHEV-H via TUI.
7. Enter "Select the disk to use for booting RHEV Hyervisor" page 
8. Plug that USB media(has been installed rhev-h) into local host.
9. Refresh the page and select USB device to use for booting RHEV-H.
10.Then enter "Please select the disk(s) to use for installation of RHEV Hyervisor" page.
11.Select USB media(has been installed rhev-h) to use for installation of RHEV-H.
 
Prompt that "Existing HostVG Detected on /dev/mapper/1SanDiskp4, Please reboot from media and choose Reinstall",then click "Reboot" button. rhev-h will reboot.
So this bug has been fixed, change the status into "VERIFIED"
Comment 12 errata-xmlrpc 2013-02-28 11:46:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.