Bug 88094 - Unable to sign email in kmail
Summary: Unable to sign email in kmail
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork
Version: 9
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 15:50 UTC by Dennis Gilmore
Modified: 2007-03-27 04:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-05 12:47:36 UTC


Attachments (Terms of Use)

Description Dennis Gilmore 2003-04-05 15:50:40 UTC
Description of problem: 
I have set Kmail to sign my mail and the default inline plugin prompts for my password  but 
rejects the correct password 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.Create a new mail message 
2. hit send 
3. Fill in prompts for Password 
     
     
Actual results: 
Password incorectly rejected as false	and mail not sent 
 
Expected results: 
password accepted and mail sent 
 
 
Additional info:

Comment 1 Ali-Reza Anghaie 2003-04-14 01:04:25 UTC
Umm. Lots of questions. 
 
Sign your email using ???  GnuPG? 
 
Outside of KMail does GnuPG work fine for you? Any errors or warning when running it from 
CLI? What versions of GnuPG? Kmail? 
 
FYI, Kmail in RHL 9 isn't setup for PGP/MIME and the inline plugin will still do non-RFC 
compliant signatures. But you're not even that far yet... 

Comment 2 Dennis Gilmore 2003-04-14 13:06:28 UTC
Yes signing my email with gnupg.  I have since gotten it working by building the necessary 
packages and adding the necessary plugin.  in the past i have used evolution  but have 
switched to kmail for various reasons.  There seems to be something that is stopping the 
default inline plugin from accepting my password as valid. im using Red Hat packages from 9 

Comment 3 Ali-Reza Anghaie 2003-04-14 13:42:20 UTC
Hrmm. Basic signing (non-RFC-compliant) worked for me fine. I compiled the additional 
packages to get PGP/MIME (didn't worry about S/MIME). I'd suggest closing the bug unless 
you really think you've found something that was repeatable and you'd be able to provide your 
setup (minus key). Cheers, -Ali 

Comment 4 Dennis Gilmore 2003-05-05 12:47:36 UTC
works for other users on the same system.  though i am using packages for
PGP/MIME  now


Note You need to log in before you can comment on or make changes to this bug.