Bug 880972 - [Intel Fedora18 BUG] Second RAID1 volume with size equal 0 can be created and system hangs
[Intel Fedora18 BUG] Second RAID1 volume with size equal 0 can be created and...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
18
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jes Sorensen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 05:05 EST by Lukasz Dorau
Modified: 2013-07-04 22:11 EDT (History)
5 users (show)

See Also:
Fixed In Version: mdadm-3.2.6-19.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-05 01:52:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukasz Dorau 2012-11-28 05:05:34 EST
Description of problem:
It is possible to create second RAID1 volume with size equal 0. When resync of first RAID1 volume is finished, system hangs.

Version-Release number of selected component (if applicable):
3.2.6-1.fc18

How reproducible:
Always

Steps to Reproduce:
(disks of size 56 GB)
1. # mdadm -C /dev/md/imsm -amd -e imsm -n 2 /dev/sda /dev/sdb -R
2. # mdadm -C /dev/md/vol1 -amd -l1 --size 54682172 -n 2 /dev/sda /dev/sdb -R
3. # mdadm -C /dev/md/vol2 -amd -l1 -n 2 /dev/sda /dev/sdb -R
  
Actual results:
Second RAID1 volume of size equal 0 is created and system hangs. 

Expected results:
Creating of second RAID1 volume of size 0 should not be possible.

Additional info:
The following patch fixes this bug:
   commit 066e92f017df22c879c455494d2c1743ef7f3aca
   Create.c: check if freesize is equal 0
http://git.neil.brown.name/git?p=mdadm.git;a=commitdiff;h=066e92f017df22c879c455494d2c1743ef7f3aca
Comment 1 Fedora Update System 2012-12-06 08:48:41 EST
mdadm-3.2.6-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-3.fc18
Comment 2 Lukasz Dorau 2012-12-06 10:26:47 EST
There is a typo done while porting this patch to mdadm-3.2.6-3.fc18:

There is a line in the original patch (http://git.neil.brown.name/git?p=mdadm.git;a=commitdiff;h=066e92f017df22c879c455494d2c1743ef7f3aca):

+ pr_err("no free space left on %s\n", dname); 

It was ported to mdadm-3.2.6-3.fc18 as (in Create.c:411):
+ fprintf(stderr, Name "no free space left on %s\n", dname);

It is wrong. 

The correct one should be (in Create.c:411):
+ fprintf(stderr, Name ": no free space left on %s\n", dname);

Because now the message is following:
mdadmno free space left on /dev/sda

and the correct one should be:
mdadm: no free space left on /dev/sda

Could you correct that?
Comment 3 Fedora Update System 2012-12-06 15:08:39 EST
Package mdadm-3.2.6-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mdadm-3.2.6-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19855/mdadm-3.2.6-3.fc18
then log in and leave karma (feedback).
Comment 4 Lukasz Dorau 2012-12-07 06:28:48 EST
(In reply to comment #3)
> Package mdadm-3.2.6-3.fc18:
> * should fix your issue,

The issue mentioned in comment #2 is not fixed in mdadm-3.2.6-3.fc18
Comment 5 Fedora Update System 2012-12-11 01:36:18 EST
mdadm-3.2.6-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-5.fc18
Comment 6 Lukasz Dorau 2012-12-11 03:25:29 EST
Intel has tested mdadm-3.2.6-5.fc18 and confirms the bug is fixed in this build.
Comment 7 Fedora Update System 2012-12-11 04:21:28 EST
mdadm-3.2.6-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-4.fc17
Comment 8 Fedora Update System 2012-12-11 04:27:45 EST
mdadm-3.2.6-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-4.fc16
Comment 9 Fedora Update System 2012-12-11 11:30:24 EST
mdadm-3.2.6-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-7.fc18
Comment 10 Fedora Update System 2012-12-11 11:39:09 EST
mdadm-3.2.6-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-7.fc17
Comment 11 Fedora Update System 2012-12-11 11:47:44 EST
mdadm-3.2.6-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-7.fc16
Comment 12 Lukasz Dorau 2012-12-13 03:41:17 EST
Intel has tested the package mdadm-3.2.6-7.fc18 and confirms the bug is fixed in this build.
Comment 13 Fedora Update System 2013-01-04 12:03:51 EST
mdadm-3.2.6-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-8.fc17
Comment 14 Fedora Update System 2013-01-04 12:11:11 EST
mdadm-3.2.6-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-8.fc18
Comment 15 Fedora Update System 2013-01-05 01:50:38 EST
mdadm-3.2.6-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-01-05 01:52:49 EST
mdadm-3.2.6-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-01-09 00:47:19 EST
mdadm-3.2.6-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-11.fc18
Comment 18 Fedora Update System 2013-01-11 18:18:31 EST
mdadm-3.2.6-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-03-20 17:38:43 EDT
mdadm-3.2.6-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-04-23 07:27:23 EDT
mdadm-3.2.6-18.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-18.fc18
Comment 21 Fedora Update System 2013-04-24 09:54:42 EDT
mdadm-3.2.6-19.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-19.fc18
Comment 22 Fedora Update System 2013-07-04 22:11:36 EDT
mdadm-3.2.6-19.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.