Bug 880979 - 30s timeout at boot due systemd dbus interaction: RequestName() failed: Access denied
Summary: 30s timeout at boot due systemd dbus interaction: RequestName() failed: Acces...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-28 10:16 UTC by Jiri Cerny
Modified: 2012-12-20 11:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-20 11:11:51 UTC
Type: Bug


Attachments (Terms of Use)
edited output of journalctl (4.84 KB, application/octet-stream)
2012-11-28 10:16 UTC, Jiri Cerny
no flags Details
tar.gz of /etc/dbus-1 (7.64 KB, application/x-gzip)
2012-11-28 13:28 UTC, Jiri Cerny
no flags Details

Description Jiri Cerny 2012-11-28 10:16:27 UTC
Created attachment 653412 [details]
edited output of journalctl

Description of problem: With up-to-date F18, I see approx 30sec timeout at boot, probably due to dbus and systemd interaction: 


Version-Release number of selected component (if applicable): F18-beta fully updated



Additional info:  the relevant lines from journalctl attached

Comment 1 Michal Schmidt 2012-11-28 12:40:30 UTC
The "RequestName() failed: Access denied" error has been reported before, but it could not be reproduced then.

Could you attach a tarball of the /etc/dbus-1/ directory? It's possible that a package installed a wrong policy file there somewhere, causing the problem.

Also check if the error is still reproducible when booting with "enforcing=0" on the kernel command line (to put SELinux into permissive mode).

Comment 2 Jiri Cerny 2012-11-28 13:27:51 UTC
I tried disabling the selinux first and the problem went away. When I reenable it, I see in audit.log the following line (time corresponds to the time when the message RequestName() failed appears)

type=USER_AVC msg=audit(1354108288.999:98): pid=620 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=signal interface=org.freedesktop.systemd1.Activator member=ActivationRequest dest=org.freedesktop.systemd1 spid=613 tpid=1 scontext=system_u:system_r:accountsd_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=dbus  exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?' 


tar of /etc/dbus-1 is attached

Comment 3 Jiri Cerny 2012-11-28 13:28:49 UTC
Created attachment 653527 [details]
tar.gz of /etc/dbus-1

Comment 4 Jiri Cerny 2012-12-11 19:38:08 UTC
The bug disappeared today after updating. Feel free to close it.


Note You need to log in before you can comment on or make changes to this bug.