Bug 88104 - uinitialized variable used for __ieee754_gammal_r(NaN,)
uinitialized variable used for __ieee754_gammal_r(NaN,)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-05 14:02 EST by John Reiser
Modified: 2016-11-24 10:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 15:21:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2003-04-05 14:02:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
__tgammal(NaN) tests an uninitialized local variable because __ieee754_gammal_r
does not set *signgam for a NaN.

-----sysdeps/generic/w_tgammal.c:37
        y = __ieee754_gammal_r(x,&local_signgam);
        if (local_signgam < 0) y = -y;
-----

-----sysdeps/ieee754/ldbl-96/e_gammal_r.c:47
  if ((es & 0x7fff) == 0x7fff && ((hx & 0x7fffffff) | lx) != 0)
    /* NaN, return it.  */
    return x;
-----

Version-Release number of selected component (if applicable):
glibc-2.3.2-11.9

How reproducible:
Always

Steps to Reproduce:
1.Run testcase math/test-ldouble and watch when x==NaN.
2.
3.
    

Actual Results:  local_signgam is tested even though its value has not been set.

Expected Results:  local_signgam is tested only when its value has been set.

Additional info:

It would be more efficient if __ieee754_gammal_r just set "*signgam = 0;"
immediately upon entry, instead of for [almost-]every boundary case.
Comment 1 Jakub Jelinek 2003-04-09 15:21:40 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-136.html

Note You need to log in before you can comment on or make changes to this bug.