Bug 881051 - hinting regression with liberation sans
hinting regression with liberation sans
Status: CLOSED DUPLICATE of bug 856239
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 09:09 EST by Pierre Ossman
Modified: 2012-12-06 14:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 14:07:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of bad hinting (24.40 KB, image/png)
2012-11-28 09:09 EST, Pierre Ossman
no flags Details

  None (edit)
Description Pierre Ossman 2012-11-28 09:09:59 EST
Created attachment 653557 [details]
example of bad hinting

Upgraded to F18 beta today, and all of a sudden everything looks like shit in Firefox. After some investigation, it turns out that hinting for Liberation Sans seems to be utterly broken.

See comparison screen shot from Firefox on F17 and F18.

Also tried forcing Liberation Sans in Epiphany, which rendered the same (i.e. badly).
Comment 1 Pravin Satpute 2012-11-28 09:16:41 EST
Thanks for reporting this issue. We are going to discuss in tomorrow i18n meeting whether to revert back liberation 2.0 fonts. Will update it here.
Comment 2 Ilya 2012-11-28 09:47:13 EST
Possible duplicate:

https://bugzilla.redhat.com/show_bug.cgi?id=856239
Comment 3 Ilya 2012-11-28 09:53:22 EST
Another screenshot:

http://storage1.static.itmages.ru/i/12/1109/h_1352416963_1081608_4a4c6af4c4.png

Some issues noticesed:

* In the right picture some single vertical lines take several pixels while similar lines in other letters (or other parts of the same letter like in Russian ш in the word шрифтов or the П letter) occupy 1 pixel. It is incorrect that one vertical line in П is thicker than the other.
This unevenness creates an effect of blots spread through the text. 

* Due to subpixel smoothing this also creates an "rainbow" effect with colorful (reddish) play while the text in the text in the left window looks evenly black (in the both examples the subpixel smoothing is on).

* Some thick letters in the right window fuse such as letters "ым" in the word "лицензированными".

* The broken hinting also makes the lower part of the "в" letter to appear smaller than the upper part (look at the word "шрифтов"). This is incorrect behavior.
Comment 4 Pravin Satpute 2012-12-06 14:07:36 EST

*** This bug has been marked as a duplicate of bug 856239 ***

Note You need to log in before you can comment on or make changes to this bug.