Bug 881055 - [RHEVM] [backend] [Host Networking] [TEXT] Bridged network rhevm is attached to multiple interfaces: <UNKNOWN> on Host
[RHEVM] [backend] [Host Networking] [TEXT] Bridged network rhevm is attached ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
low Severity low
: ---
: 3.3.0
Assigned To: Moti Asayag
Martin Pavlik
network
:
Depends On: 1004675
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-11-28 09:20 EST by Martin Pavlik
Modified: 2016-02-10 14:54 EST (History)
8 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log_collector (2.98 MB, application/x-xz)
2012-11-28 09:20 EST, Martin Pavlik
no flags Details
screenshot (256.46 KB, image/png)
2012-11-28 09:22 EST, Martin Pavlik
no flags Details
screenshot_si27.2 (195.42 KB, image/png)
2013-02-22 04:16 EST, Martin Pavlik
no flags Details
screenshot_sf8 (245.75 KB, image/png)
2013-02-22 04:16 EST, Martin Pavlik
no flags Details
engine_sf8.tgz (408.56 KB, application/x-compressed-tar)
2013-02-22 04:43 EST, Martin Pavlik
no flags Details
vdsm.log_sf8 (19.34 KB, application/x-compressed-tar)
2013-02-22 04:47 EST, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12155 None None None Never
oVirt gerrit 19291 None None None Never

  None (edit)
Description Martin Pavlik 2012-11-28 09:20:51 EST
Created attachment 653564 [details]
log_collector

Description of problem:
If RHEL host with vdsm-4.9-113.4.el6_3 (3.0 compatible) is reassigned from 3.0 cluster to 3.1 cluster following error message appears in Events (see screenshot)

Bridged network rhevm is attached to multiple interfaces: <UNKNOWN> on Host dell-06.

This error message does not make sense and it should not appear in events.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.1.0-32.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. install RHEL host with vdsm-4.9-113.4.el6_3
2. add the host to RHEVM 3.1, cluster 3.0
3. put host to maintenance -> assign host to 3.1 cluster 
4. activate the host
  
Actual results:
warning
	
Bridged network rhevm is attached to multiple interfaces: <UNKNOWN> on Host dell-06.

Expected results:
no such warning

warning

Host dell-06 is compatible with versions (3.0) and cannot join Cluster Default which is set to version 3.1.

is sufficient

Additional info:
2012-11-28 15:01:34,230 INFO  [org.ovirt.engine.core.vdsbroker.SetVdsStatusVDSCommand] (pool-3-thread-48) [3821bba9] START, SetVdsStatusVDSCommand(HostName = dell-06, HostId = 7cd56c8a-3962-11e2-8775-001a4a013f0e, status=NonOperational, nonOperationalReason=VERSION_INCOMPATIBLE_WITH_CLUSTER), log id: 40d99bea
Comment 1 Martin Pavlik 2012-11-28 09:22:24 EST
Created attachment 653565 [details]
screenshot
Comment 2 Moti Asayag 2013-01-29 04:45:42 EST
(In reply to comment #1)
> Created attachment 653565 [details]
> screenshot

Can you attach a print screen of the host interfaces sub-tab as well? 
and also the output of 'brctl show' on the host ?

By looking at the result of getVdsCaps it seems like a bug on analysing the reported interfaces:

'networks': {'rhevm': {'addr': '10.34.66.61', 'cfg': {'UUID': 'e1642599-5dce-48eb-bd8b-d9d4fa727c12', 'MTU': '1500', 'DELAY': '0', 'BOOTPROTO': 'dhcp', 'DEVICE': 'rhevm', 'TYPE': 'Bridge', 'ONBOOT': 'yes', 'IPV6INIT': 'yes'}, 'ports': ['em1'], 'netmask': '255.255.255.0', 'stp': 'off', 'gateway': '10.34.66.254'}}, 'uuid': '4C4C4544-0037-5410-8033-C4C04F39354A_90:E2:BA:04:28:C0', 'lastClientIface': 'rhevm', 'nics': {'em1': {'hwaddr': 'D0:67:E5:F0:83:5E', 'netmask': '', 'speed': 1000, 'addr': ''}, 'em2': {'hwaddr': 'D0:67:E5:F0:83:5F', 'netmask': '', 'speed': 0, 'addr': ''}, 'p1p1': {'hwaddr': '90:E2:BA:04:28:C0', 'netmask': '', 'speed': 0, 'addr': ''}, 'p1p2': {'hwaddr': '90:E2:BA:04:28:C1', 'netmask': '', 'speed': 0, 'addr': ''}}

'rhevm' network is defined on top of 'em1', therefore the error shouldn't appear at first place.

In addition, the "<UNKNOWN>" is probably due to a mismatch between the place-holder defined on the message to its replacement from code.

BRIDGED_NETWORK_OVER_MULTIPLE_INTERFACES=Bridged network ${NetworkName} is attached to multiple interfaces: ${interfaces} on Host ${VdsName}.
Comment 3 Martin Pavlik 2013-02-22 04:16:19 EST
Created attachment 701052 [details]
screenshot_si27.2
Comment 4 Martin Pavlik 2013-02-22 04:16:51 EST
Created attachment 701053 [details]
screenshot_sf8
Comment 5 Martin Pavlik 2013-02-22 04:43:10 EST
bug is still present in SF8

engine log on sf8 (engine_sf8.tgz)

2013-02-22 10:10:45,823 INFO  [org.ovirt.engine.core.bll.InstallVdsCommand] (pool-3-thread-49) [32774b73] Before Installation host 652270c2-af08-4282-ba21-c3ebb5ac67e4, dell-07
Comment 6 Martin Pavlik 2013-02-22 04:43:53 EST
Created attachment 701063 [details]
engine_sf8.tgz
Comment 7 Martin Pavlik 2013-02-22 04:47:23 EST
Created attachment 701072 [details]
vdsm.log_sf8
Comment 9 Martin Pavlik 2013-10-18 09:13:59 EDT
works in is19
Host dell-07 is compatible with versions (3.0) and cannot join Cluster CL31 which is set to version 3.1.
Comment 10 Itamar Heim 2014-01-21 17:30:14 EST
Closing - RHEV 3.3 Released
Comment 11 Itamar Heim 2014-01-21 17:30:14 EST
Closing - RHEV 3.3 Released
Comment 12 Itamar Heim 2014-01-21 17:33:17 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.